Download it now!
Bug 122348 - UI: dialogue Image properties: width/height ratio lost if immediately after changing either width or height, that is confirmed (thus dialog closed) with Enter (gen/gtk2)
Summary: UI: dialogue Image properties: width/height ratio lost if immediately after c...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.1.5
Keywords: bibisected, bisected, regression
: 121999 (view as bug list)
Depends on:
Blocks: Image-Dialog
  Show dependency treegraph
 
Reported: 2018-12-27 19:27 UTC by Lars Jødal
Modified: 2019-04-01 06:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Jødal 2018-12-27 19:27:59 UTC
Versions: Detected in 6.2.0.0.alpha1 and later. Not seen in 6.1.4.2. 

Steps to reproduce: 
1. Start from a fresh login or restart (no instances of LibreOffice run before).
2. Open a document in Writer containing an image (new or existing document). 
3. Open image properties dialogue (right-click -> Properties).
4. Check "Keep ratio" box.
5. Click in "Width" (or "Height") field and change the number using the keyboard. Do NOT leave the field (e.g. by Tab or by clicking another field).
6. Exit dialogue by pressing "Enter" or by clicking "OK".

Seen behaviour:
Width/height ratio of image is not kept. Only the manually changed width (or height) is changed.

Expected behaviour:
When "Keep ratio" is checked, then width/heigh ratio should be kept, i.e. if width is changed, then height should automatically change in proportion.

Seen in versions 6.2.x.x and higher:

Version: 6.2.0.0.alpha1 (x64)
Build ID: ff46ad24d1d3cbcea45895520483ed1fd4ff488b
CPU tråde: 8; Styresystem: Windows 10.0; Gengiver af brugergrænseflade: GL; VCL: win; 
Lokalisering: da-DK (da_DK); Calc: threaded

Version: 6.2.0.1 (x64)
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU tråde: 8; Styresystem: Windows 10.0; Gengiver af brugergrænseflade: Standard; VCL: win; 
Lokalisering: da-DK (da_DK); Sprog for brugergrænseflade: da-DK
Calc: threaded

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 49fcd3bbb30f93763fc5cb80fa6ac5cec5d00834
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-24_22:40:25
Locale: da-DK (da_DK); UI-Language: en-US
Calc: threaded

NOT seen in present Fresh LibreOffice 6.1.4.2, where editing of width at once also changes the number for height (when "Keep ratio" is checked).


Frequency:
Starting with step 1 (fresh start): Every time.
Starting with step 2 (no fresh start): The bug may or may not show up. It seems that if an editing of the image properties has been successful - e.g. by first performing image editing with a different LO version - then the bug does not show up. (This makes me think of an uninitialized global value of some kind, but that is only speculation.)

Tested on Windows 10 (more than a single computer).
Comment 1 Dieter 2018-12-27 21:51:01 UTC
I can't confirm with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 2 Lars Jødal 2018-12-28 07:45:00 UTC
(In reply to Lars Jødal from comment #0)
> Versions: Detected in 6.2.0.0.alpha1 and later. Not seen in 6.1.4.2. 
> 
> Steps to reproduce: 
> 1. Start from a fresh login or restart (no instances of LibreOffice run
> before).
> 2. Open a document in Writer containing an image (new or existing document). 
> 3. Open image properties dialogue (right-click -> Properties).
> 4. Check "Keep ratio" box.
> 5. Click in "Width" (or "Height") field and change the number using the
> keyboard. Do NOT leave the field (e.g. by Tab or by clicking another field).
> 6. Exit dialogue by pressing "Enter" or by clicking "OK".

Sorry, it seems that my report was inaccurate. The bug is only seen when pressing "Enter" in step 6, not if "OK" is clicked with the mouse. Doing this, the bug appears to be reproducible every time, so step 1 is not needed. Thus:

Steps to reproduce:
(Step 1 can be omitted)
Steps 2-5: As above
Step 6. Exit dialogue by pressing "Enter".

Reproducible: Every time

Reset of user profile: No
Comment 3 Telesto 2018-12-28 09:59:36 UTC
Repro (when pressing enter)
Version: 6.3.0.0.alpha0+
Build ID: beae6c7a7f163daad0d4dea63a3d403af2745fd1
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-06_23:55:16
Locale: en-US (nl_NL); UI-Language: en-US
Calc: CL

but not with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 4 raal 2018-12-29 06:52:58 UTC
I can not confirm with Version: 6.3.0.0.alpha0+
Build ID: 993913469e74e9db9743004bbe36aa412411671c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 5 Dieter 2018-12-30 07:09:30 UTC
With pressing Enter I can confirm in 

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

but not in

Version: 6.1.4.2 (x64)
Build-ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded


Until now the bug wasn't confirmed with Linux, so I changed hardware to Windows.
Comment 6 Cor Nouws 2019-01-04 11:59:19 UTC
(In reply to Lars Jødal from comment #2)

> Sorry, it seems that my report was inaccurate. The bug is only seen when
> pressing "Enter" in step 6, not if "OK" is clicked with the mouse. Doing
> this, the bug appears to be reproducible every time, so step 1 is not
> needed. Thus:

I know there are more dialogs where confirming with Enter, without explicitly leaving a field/box before that, ignores the setting made in that control.
Got used to it and do a Tab first, but shouldn't be that way indeed.
Comment 7 Cor Nouws 2019-01-04 12:06:34 UTC
indeed not a problem on my Linux box with Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded
Comment 8 Xisco Faulí 2019-01-07 23:54:16 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=998d11b44eb3c57583703fa0df67e087ba187195

author	Caolán McNamara <caolanm@redhat.com>	2018-11-21 21:21:35 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-11-23 09:54:21 +0100
commit	998d11b44eb3c57583703fa0df67e087ba187195 (patch)
tree	882c147cdd408421554f647763cc9d3a3b117d8c
parent	626504ee27d853d70a5a8b3b62d69313b9b6eb98 (diff)
weld SwFramePage

Bisected with: bibisect-linux64-6.2

Adding Cc: to Caolán McNamara
Comment 9 Commit Notification 2019-01-09 16:13:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6bbb384bf6334eb9f207f4098820e6852e21325a%5E%21

Resolves: tdf#122348 make return in spinbutton signal value change

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2019-01-09 16:15:20 UTC
backport to 6-2 in gerrit
Comment 11 Xisco Faulí 2019-01-10 11:40:42 UTC
*** Bug 121999 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2019-01-10 11:42:37 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: b8f497a06d585dbae3adadb4d177fe84fdb1b5fa
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this!

Cherry-picked to 6-1 for bug 121999 -> https://gerrit.libreoffice.org/#/c/66083/
Comment 13 Commit Notification 2019-01-10 11:55:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3f1e853b7b6d63f4e6fea70a5ef0aa94668ab16e%5E%21

Resolves: tdf#122348 make return in spinbutton signal value change

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-01-11 17:44:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/154c72769d39258c5efbc35175824d08706a9314%5E%21

Resolves: tdf#122348 make return in spinbutton signal value change

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Lars Jødal 2019-04-01 06:12:16 UTC
I can confirm the fix with LO 6.2.2

Version: 6.2.2.2 (x64)
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU tråde: 4; Styresystem: Windows 10.0; Gengiver af brugergrænseflade: GL; VCL: win; 
Lokalisering: da-DK (da_DK); Sprog for brugergrænseflade: da-DK
Calc: threaded