Download it now!
Bug 122355 - HELP button in Format Cells no longer opens help on Format Cells (it opens top of Help)
Summary: HELP button in Format Cells no longer opens help on Format Cells (it opens to...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.2 target:6.4....
Keywords: notBibisectable, regression
: 123507 (view as bug list)
Depends on:
Blocks: Help-Link
  Show dependency treegraph
 
Reported: 2018-12-28 02:38 UTC by Jim Avera
Modified: 2019-08-29 04:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2018-12-28 02:38:58 UTC
Description:
The Format Cells dialog has a dedicated "Help" button which used to open Help about the features on the Format Cells dialog tab being viewed.

Now it just starts help at the top level of Calc. 

Functional regression from 5.x

Steps to Reproduce:
1. Open a Calc spreadsheet
2. Select a cell
3. Rightclick->Format Cells; select "Numbers" tab
4. Click the "Help" button

Actual Results:
Browser opens at top level of entire help docset for Calc

Expected Results:
Should open help for the features in the dialog


Reproducible: Always


User Profile Reset: No



Additional Info:
Regression from the old help system in 5.x
Comment 2 Olivier Hallot 2019-02-15 22:24:09 UTC
Cause: The URL passed to the Help system *with the dialog Help button* has changed and is wrong.

For the Calc Format cell dialog, the URL passed to the Help system *with the Help button* is always

file:///home/tdf/git/core/instdir/help/index.html?Target=scalc/modules/scalc/ui/formatcellsdialog/help&Language=pt-BR&System=UNIX&Version=6.3

independent of the tab displayed in the dialog. Since there is no page with bookmark

Target=scalc/modules/scalc/ui/formatcellsdialog/help

the default page is open, which is the Module Help main entry page.

Not passing the actual tab displayed in the dialog with the dialog Help button, all tabs will open the default page, breaking the Help system.

It happens with many other dialogs, including Writers Paragraph dialog.

With Writer's Format Paragraph dialog, the URL sent to the Help system is 

file:///home/tdf/git/core/instdir/help/index.html?Target=swriter/modules/swriter/ui/paradialog/help&Language=pt-BR&System=UNIX&Version=6.3

which also shows an inexistant bookmark within the Help pages:

Target=swriter/modules/swriter/ui/paradialog/help

But, if the same dialog Help is invoked with F1 key, then the right URL is sent to the Help system:

file:///home/tdf/git/core/instdir/help/index.html?Target=swriter/cui/ui/textflowpage/checkAuto&Language=pt-BR&System=UNIX&Version=6.3

Target=swriter/cui/ui/textflowpage/checkAuto
Comment 3 russell 2019-02-17 02:36:06 UTC
Confirm at LO Version 6.2.0.3

Work around per #2: Use F1 and not the Help button
Comment 4 raal 2019-02-17 06:49:13 UTC
*** Bug 123507 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2019-02-18 17:20:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/77a0cb2839c7770346bf97a273a36715a6cc0be4%5E%21

Resolves: tdf#122355 search help for active notebook page

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2019-02-18 17:35:25 UTC
fixed in master, backport to 6-2 in gerrit
Comment 7 Commit Notification 2019-02-19 17:29:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3432a0c5bb94e5c6f4dfa62e6f26939e69b8c6b8%5E%21

Resolves: tdf#122355 search help for active notebook page

It will be available in 6.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Jim Avera 2019-02-19 21:23:50 UTC
Are the linux builds broken? 

The most recent seems to be a week old (dated February 12):

https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/

Index of /daily/master/Linux-rpm_deb-x86_64@86-TDF/
2019-02-05_03.46.54/	-	2019-Feb-05 12:35
2019-02-05_22.52.08/	-	2019-Feb-06 08:09
2019-02-06_18.24.35/	-	2019-Feb-07 02:33
2019-02-08_12.51.03/	-	2019-Feb-08 21:53
2019-02-09_07.59.38/	-	2019-Feb-09 15:52
2019-02-10_00.51.32/	-	2019-Feb-10 08:54
2019-02-10_17.50.13/	-	2019-Feb-11 01:45
2019-02-11_21.25.30/	-	2019-Feb-12 06:52
2019-02-12_16.47.45/	-	2019-Feb-13 01:54
current/	-	2019-Feb-13 01:54
Comment 9 Xisco Faulí 2019-03-12 12:09:20 UTC
(In reply to Jim Avera from comment #8)
> Are the linux builds broken? 

Hello Jim,
New builds are available since you wrote the comment. Could you please give it a try now ?
Comment 10 Xisco Faulí 2019-03-12 12:22:11 UTC
Hi Caolán,
Do you think this should be cherry-picked to 6.1 branch as well ?
Comment 11 Jim Avera 2019-03-12 19:37:55 UTC
Hmm... the fix does NOT seem to work in master built March 3, 2019

Version: 6.3.0.0.alpha0+
Build ID: bbc5347be70d11d187cd537dd73cdab584def719
CPU threads: 12; OS: Linux 4.18; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-03-03_20:19:18
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

STEPS TO REPRODUCE:

1. run /path/to/soffice --calc
2. Right-click any cell->Format Cells
3. Click "Numbers" tab
4. Click "Help"

RESULTS: Opes top of Calc help

The URL in the browser address bar is
 file:///path/to/install/opt/libreofficedev6.3/help/en-US/text/scalc/main0000.html?System=UNIX&DbPAR=CALC
Comment 12 Jim Avera 2019-03-12 22:04:13 UTC
Actually, the 64-bit Linux builds still seem to be broken... Today is March 12 and the most recent build I could find in
  https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@anything
is dated March 3.

Strangely, the mod-date listed for the *directory* https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/ is March 11, but it only contains builds dated through 2019-03-03_20.19.18/

Am I looking in the wrong place?
Comment 13 Xisco Faulí 2019-03-13 17:00:02 UTC
(In reply to Jim Avera from comment #12)
> Actually, the 64-bit Linux builds still seem to be broken... Today is March
> 12 and the most recent build I could find in
>  
> https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@anything
> is dated March 3.
> 
> Strangely, the mod-date listed for the *directory*
> https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/
> is March 11, but it only contains builds dated through 2019-03-03_20.19.18/
> 
> Am I looking in the wrong place?

This one is recent: https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86@87-TDF/
Comment 14 Xisco Faulí 2019-03-13 18:26:28 UTC
I downloaded 

Versión: 6.2.2.1
Id. de compilación: fcd633fb1bf21b0a99c9acb3ad6e526437947b01
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

and the issue is still reproducible...
Comment 15 Jim Avera 2019-03-13 19:15:22 UTC
@Xisco
> This one is recent:
> https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86@87-TDF/

But isn't that a 32-bit build (x86, not x86_64) ?
Comment 16 Caolán McNamara 2019-03-13 21:16:50 UTC
still works fine for me
Comment 17 Commit Notification 2019-08-16 07:19:09 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/34e83dd95260d534464ff9a61eddefdde136013c%5E%21

tdf#126007 tdf#122355 online help won't look into a dialog notebook

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Caolán McNamara 2019-08-16 14:07:44 UTC
I believe this is fixed now. Difference in online and offline help fallback worked
Comment 19 Jim Avera 2019-08-16 22:13:31 UTC
DISconfirming (i.e. it is not yet fixed) in master:

Version: 6.4.0.0.alpha0+
Build ID: 8387a6db641b29e6ff3c2f4cdc4688f538cbe35f
CPU threads: 12; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-08-09_06:28:42
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 20 Xisco Faulí 2019-08-19 06:12:55 UTC
(In reply to Jim Avera from comment #19)
> DISconfirming (i.e. it is not yet fixed) in master:
> 
> Version: 6.4.0.0.alpha0+
> Build ID: 8387a6db641b29e6ff3c2f4cdc4688f538cbe35f
> CPU threads: 12; OS: Linux 5.0; UI render: default; VCL: gtk3; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2019-08-09_06:28:42
> Locale: en-US (en_US.UTF-8); UI-Language: en-US
> Calc: threaded

Hi Jim,
Please try with a more recent version. The one you used is from 2019-08-09, Caolán's commit is from 2019-08-16
Comment 21 Xisco Faulí 2019-08-19 10:27:23 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: cbe9601e5972ec1c466311e0b148a9fbe8cda4d1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 22 Jim Avera 2019-08-20 04:59:25 UTC
Sorry, I downloaded the latest but it seems to be old.

@Xisco: Did you build your own, or download a master build for Linux?  

https://dev-builds.libreoffice.org/daily/master/ seems to have nothing later than 2019-08-09 which is now 10 days old. 

Is that no longer the right place to find builds of master?
Comment 23 Jim Avera 2019-08-26 19:30:46 UTC
Ok, I too confirm it's fixed in master build of 2019-08-21_09:30:10

And, to docs look really good!

Thanks to all.
Comment 24 Commit Notification 2019-08-29 04:18:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/8ec2af41a40b56155c50329417459749dbdf5af8%5E%21

tdf#126007 tdf#122355 online help won't look into a dialog notebook

It will be available in 6.2.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2019-08-29 04:19:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/d781aec2ae62e59bb71b05904b240586b6c899dd%5E%21

tdf#126007 tdf#122355 online help won't look into a dialog notebook

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.