Download it now!
Bug 122385 - EDITING Calc freezes at copy or cut
Summary: EDITING Calc freezes at copy or cut
Status: RESOLVED DUPLICATE of bug 122435
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Cut-Copy
  Show dependency treegraph
 
Reported: 2018-12-30 23:28 UTC by Stefan_Lange_KA@T-Online.de
Modified: 2019-01-16 22:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
zip file with documents to show the bug (72.60 KB, application/x-zip-compressed)
2018-12-30 23:28 UTC, Stefan_Lange_KA@T-Online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan_Lange_KA@T-Online.de 2018-12-30 23:28:16 UTC
Created attachment 147902 [details]
zip file with documents to show the bug

In special cases Calc freezes, when cell content should be cut or copied.

Reproducing the problem:
- open "altix_Nummern_Test_Einfrieren_V4d2.ods" or "altix_Nummern_Test_Einfrieren_V4d2.ods" from attached zip file
- copy (e.g.) row 14 and paste it into (e.g.) row 11 
- select a text in any cell and try to copy or cut it
Result: Calc freezes (doesn't respond)

The freeze occurs also when other rows are copied and pasted (therefor the "(e.g.)". Ooccasionally Calc doesn't freeze  at copy or cut, but I couldn't reproduce these cases until now.

As I have seen formulas reffering other cells are causing the freeze. When the same procedure is done with "altix_Nummern_Test_Einfrieren_V4l_no_freeze.ods" from attached zip file Calc doesn't freeze.

Tested with Version: 6.2.0.1 (x64)
Build-ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
and with 
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 2c5c20b19c349a4b7f6d78d69d8d57f9af5c351c
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-23_00:18:09
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
and not reproduced with
Version: 6.1.4.2 (x64)
Build-ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL
Comment 1 Oliver Brinzing 2018-12-31 09:43:56 UTC
> Reproducing the problem:
> - open "altix_Nummern_Test_Einfrieren_V4d2.ods" or
> "altix_Nummern_Test_Einfrieren_V4d2.ods" from attached zip file
> - copy (e.g.) row 14 and paste it into (e.g.) row 11 
> - select a text in any cell and try to copy or cut it
> Result: Calc freezes (doesn't respond)

reproducible
Comment 2 Xisco Faulí 2019-01-16 22:00:33 UTC
Seems to be similar to bug 122435.
@Oliver Brinzing, @Stefan Lange, if you see it's a regression as indicated in the description, please add the regression keyword...

*** This bug has been marked as a duplicate of bug 122435 ***