Download it now!
Bug 122407 - Toobar icons to insert row/colun in table are misleading with Colibre
Summary: Toobar icons to insert row/colun in table are misleading with Colibre
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: andreas_k
URL:
Whiteboard: target:6.3.0 target:6.2.0.2
Keywords:
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2019-01-01 16:36 UTC by William Gathoye
Modified: 2019-01-13 18:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Issue with toolbar in Writer (10.28 KB, image/jpeg)
2019-01-01 16:37 UTC, William Gathoye
Details
Breeze new icon are not consistent (55.29 KB, image/png)
2019-01-04 16:01 UTC, William Gathoye
Details
Sifr still needs improvement (1.49 KB, image/png)
2019-01-04 16:01 UTC, William Gathoye
Details
Colibre SVG variant on Calc (13.79 KB, image/png)
2019-01-13 18:08 UTC, William Gathoye
Details
Colibre SVG variant in Writer (5.85 KB, image/png)
2019-01-13 18:09 UTC, William Gathoye
Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Gathoye 2019-01-01 16:36:36 UTC
Description:
Insert line above and insert line below, or for Insert column before or after, the icons are inverted.

For example with Insert line above, we intend to have the + above in the icon, while it is defined below. This leads to issues when inserting rapidly columns when taking notes at the university for example. We cannot see the line/row properly in the icon, only the + symbol is clearly visible.

Other icons theme are not impacted. Breeze could be better though in this regard as well.

Products impacted: Writer and Calc

Steps to Reproduce:
1. Insert a table
2. Try to insert a column or a row using the toolbar
3. Try to achieve this without having to restart again

Actual Results:
Misleading comprehension of the icon

Expected Results:
Immediate comprehension about how the icon work


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 William Gathoye 2019-01-01 16:37:11 UTC
Created attachment 147918 [details]
Issue with toolbar in Writer
Comment 2 Commit Notification 2019-01-01 21:20:33 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f6206244eba41a77bfe0629b2a16b6670f47aa6f%5E%21

tdf#122407 update insert rows columns icons

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2019-01-01 21:20:42 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/914955e5e927eea9a1e2c81f2682f2510ade5be2%5E%21

tdf#122407 update insert rows columns icons

It will be available in 6.2.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 William Gathoye 2019-01-04 16:00:23 UTC
Thanks this partially fixed the issue.

Colibre is now much more understandable.

However, with latest master build for Windows (32 bits at this time), we can see the Breeze color scheme has been only updated for the SVG version. Bitmap based is still the same as before. And for the SVG variant, the icons you changed are now not the same as the others. I don't know if this is intended. (cf. new screenshot).

Also, with Sifr, this is still unclear. Maybe for the darker gray column/row you displayed in the icon, this could be better to put that darker column/row upper/lower, more at the left/right depending on the icon? (cf. screenshot as well).
Comment 5 William Gathoye 2019-01-04 16:01:18 UTC
Created attachment 148037 [details]
Breeze new icon are not consistent
Comment 6 William Gathoye 2019-01-04 16:01:42 UTC
Created attachment 148038 [details]
Sifr still needs improvement
Comment 7 BogdanB 2019-01-13 13:31:44 UTC
(In reply to William Gathoye from comment #6)
> Created attachment 148038 [details]
> Sifr still needs improvement

I use Sifr and everything is ok. An arrow up means a new row up. 
Please explain the problem with sifr.
Comment 8 BogdanB 2019-01-13 13:33:31 UTC
About Colibre, everything is ok now.

Verified on
Version: 6.3.0.0.alpha0+
Build ID: be8897d9c63a77b223a9c0aed1d2eb689e0e0082
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-02_04:49:04
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 William Gathoye 2019-01-13 16:53:39 UTC
For Sifr please see https://bugs.documentfoundation.org/show_bug.cgi?id=122488
Comment 10 William Gathoye 2019-01-13 18:08:06 UTC
Regarding CoLibre, I checked this is indeed fixed for 6.3 fr the bitmap version.

There are still rendering (? unless these are not related to renderin) issues with the SVG version of colibre.

See the two following images I provide.
Comment 11 William Gathoye 2019-01-13 18:08:41 UTC
Created attachment 148292 [details]
Colibre SVG variant on Calc
Comment 12 William Gathoye 2019-01-13 18:09:04 UTC
Created attachment 148293 [details]
Colibre SVG variant in Writer
Comment 13 William Gathoye 2019-01-13 18:11:13 UTC
I haven't been able to test the 6.2 branch to see if this was fixed because the latest build on Windows for the branch 6.2 is not recent enough.

The branch 6.3 I tested is the following build
Version: 6.3.0.0.alpha0+
Build ID: 6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08
master~2019-01-09_00.08.42_LibreOfficeDev_6.3.0.0.alpha0_Win_x86.msi