Download it now!
Bug 122409 - Print and PDF export issue with RTL formulas
Summary: Print and PDF export issue with RTL formulas
Status: RESOLVED DUPLICATE of bug 115967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:pdf, regression
Depends on:
Blocks: PDF-Export RTL-Arabic
  Show dependency treegraph
 
Reported: 2019-01-01 17:26 UTC by Mohamed Anis MANI
Modified: 2019-09-26 11:07 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
This is the exported PDF file. (16.05 KB, application/pdf)
2019-01-02 14:45 UTC, Mohamed Anis MANI
Details
The source file (12.31 KB, application/vnd.oasis.opendocument.text)
2019-01-04 15:28 UTC, Mohamed Anis MANI
Details
terminal output from bibisect in linux 64-6.0 repository (2.97 KB, text/plain)
2019-01-10 00:51 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohamed Anis MANI 2019-01-01 17:26:46 UTC
Description:
I often use LibreOffice to write mathematical exams in Arabic (Right to left display). 

The formulas display well in the Writer when editing but when I try to print or export the document to PDF the formulas doesn't render well.

Steps to Reproduce:
1. Switch to RTL typing mode
2. Insert a formula in the document
3. Try to export to PDF or to print

Actual Results:
The formulas doesn't render well

Expected Results:
The formulas have to render exactly like in Writer.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Dieter 2019-01-02 08:01:17 UTC Comment hidden (obsolete)
Comment 2 Mohamed Anis MANI 2019-01-02 14:45:04 UTC
Created attachment 147937 [details]
This is the exported PDF file.
Comment 3 raal 2019-01-02 21:52:44 UTC
Please attach also source document.
Comment 4 Mohamed Anis MANI 2019-01-04 15:28:56 UTC
Created attachment 148036 [details]
The source file
Comment 5 Timur 2019-01-04 16:28:37 UTC
No repro 5.4. Repro 6.0 and 6.3+. Looks like regressionn.
Comment 6 Terrence Enger 2019-01-10 00:51:14 UTC
Created attachment 148193 [details]
terminal output from bibisect in linux 64-6.0 repository

Working on debian-buster in bibisect-linux-64-6.0 repository, I see
that that bug entered LibreOffice in

    commit 302af8c2da58719844d22483b65a9fe5b3674684
    Author: Armin Le Grand <Armin.Le.Grand@cib.de>
    Date:   Tue Aug 22 10:05:15 2017 +0200

        sw: Use primitive renderer for graphics
    
        To allow using the prepared VectorData of imported
        Metafiles (and EMF+), let Writer use a Primitive
        Renderer for Graphic output. For now, use a temp
        PrimitiveRenderer (until sw is fully adapted to
        primitives).
    
        Change-Id: Iaa39111c5ef35a052394be6e4d1b86a5a8e33068
        Reviewed-on: https://gerrit.libreoffice.org/41411
        Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
        Tested-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>

I am removing keyword bibisectRequest and adding keywords bibisected
and bisected.  I am adding Armin Le Grand to cc.
Comment 7 Xisco Faulí 2019-09-26 11:07:14 UTC
Duplicate of bug 115967

*** This bug has been marked as a duplicate of bug 115967 ***