Bug 122439 - Wrong usage missed font (Example using Sakkal Majalla font)
Summary: Wrong usage missed font (Example using Sakkal Majalla font)
Status: RESOLVED DUPLICATE of bug 61134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-03 05:38 UTC by seven
Modified: 2019-01-07 12:39 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Source for example (8.87 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-03 05:39 UTC, seven
Details
Example in word - correct (6.03 KB, image/png)
2019-01-03 05:41 UTC, seven
Details
Example in writer - not correct and need to fix (10.10 KB, image/png)
2019-01-03 05:41 UTC, seven
Details
Font Sakkal Majalla (361.41 KB, application/x-font-ttf)
2019-01-03 05:45 UTC, seven
Details
one more test in MS Office and font not installed (244.74 KB, image/png)
2019-01-03 20:12 UTC, seven
Details

Note You need to log in before you can comment on or make changes to this bug.
Description seven 2019-01-03 05:38:55 UTC
Description:
In operation system not installed front and when open document in MS Office and libreoffice displayed font is different.

Install font fix this issue, but better to use good font without installing or inform user about missed font and requirements to install it.

Steps to Reproduce:
1. Download and open file with example 
2. Open it on MS Office and LibreOffice and compare

Actual Results:
Font look different 

Expected Results:
Font look like some or like original font


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 seven 2019-01-03 05:39:47 UTC
Created attachment 147964 [details]
Source for example
Comment 2 seven 2019-01-03 05:41:12 UTC
Created attachment 147965 [details]
Example in word - correct
Comment 3 seven 2019-01-03 05:41:59 UTC
Created attachment 147966 [details]
Example in writer - not correct and need to fix
Comment 4 seven 2019-01-03 05:45:02 UTC
Created attachment 147967 [details]
Font Sakkal Majalla

Install this font fix issue with display, but not fizzy issue with inform user
Comment 5 Timur 2019-01-03 10:37:57 UTC
This report is not clear.

If this is about proper font replacement ("Font look like original font"), there are already reported bugs like Bug 61134 and Bug 64509. So this is a duplicate with example. 

But what's confusing here is that MSO finds font installed and LO not? Is it so?
I don't reproduce that. I have MSO and thus Sakkal Majalla font installed and LO also read it from the system. 

Note: Sakkal Majalla font is Copyright © 2012 Microsoft Corporation. All Rights Reserved.
Comment 6 seven 2019-01-03 19:39:22 UTC
Thank for links. It is duplicate - please close this ticket.

Also I will try to retest this issue with font different and do report later
Comment 7 seven 2019-01-03 20:12:47 UTC
Created attachment 147974 [details]
one more test in MS Office and font not installed

Font not installed but look like original. May be it have in application or changed to other similar
Comment 8 Adolfo Jayme Barrientos 2019-01-03 21:16:52 UTC
LibreOffice does already support embedding fonts into documents, but only for the native OpenDocument format. Attachment 147966 [details] shows you’ve been testing a DOCX document, where this functionality isn’t currently interoperable with MS Office’s equivalent feature.
Comment 9 seven 2019-01-04 04:47:43 UTC
So what will do - need more info from my side? need change status this ticket?

1. Document in example is have embedded font?
2. Font displayed in MS Office it is original or similar?
Comment 10 Timur 2019-01-04 12:35:21 UTC
We may have some misunderstanding here. (In reply to Adolfo Jayme from comment #8)
> LibreOffice does already support embedding fonts into documents, but only
> for the native OpenDocument format. Attachment 147966 [details] shows you’ve
> been testing a DOCX document, where this functionality isn’t currently
> interoperable with MS Office’s equivalent feature.
Thanks for clarification. But embedding is on filesave for sending to someone else.

Here is not clear how on fileopen his LO shows that this font is not installed when it should be installed, because MSO installs it by default and finds it. 

Seven, are your screenshots from the same Windows computer? 
Do not change status, just explain. 

Also, Bug 61134 just means we don't know what's LO substitution now. But if you say it's not adequate, please look around what's the most appropriate substitution with opens source fonts. And that should be noted in Bug 64509.
Comment 11 seven 2019-01-04 16:14:24 UTC
I have more misunderstanding. I will try to describe my vision

For example:

1. I get document with font Sakkal Majalla (or any other) and i never see it before. I don't know what he looks like. I continue use document with wrong font and sometime i will see document looks no good and stop using libreoffice or trying do something (i.e. this ticket).

2. For example I start using MS Office and see different with libreoffice. I found in libreoffice in font panel choose is italics - i think it is not exists font. So my step it is search and install font. But i think user must be inform about no exists font (Thanks for link to Bug 61134 and i will wait for fix this) so this ticket my be closed as duplicate, but ...

3. MS Office show font correctly and i think it is because:
  a) the font used somewhere from office application (not from OS system fonts)
  b) used other but similar font
  c) fonts is embedded in document
If MS Office also not find font is OS how me must be inform about it?

4. We can find and replace Sakkal Majalla font to similar using Bug 64509 but it is no good idea and i will wait for Bug 61134

P.S. attachment 147974 [details] done on other computer then before
Comment 12 Timur 2019-01-07 12:39:07 UTC
LO replaces font IF it doesn't exist (legally if there's no MSO on computer that installs this font).
If replacement is not correct, that's bug 64509. But we should suggest which should be a proper replacement. We don't have clear explanation and example text with different fonts.
If replacement is correct, and we just don't know what it is, it's bug 61134.
I'll close this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 61134 ***