Bug 122475 - FILEOPEN XLSX, Slicer gets replaced when opened in LO
Summary: FILEOPEN XLSX, Slicer gets replaced when opened in LO
Status: RESOLVED DUPLICATE of bug 119807
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-04 11:05 UTC by NISZ LibreOffice Team
Modified: 2019-01-04 13:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A spreadsheet that contains slicers. (23.36 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-01-04 11:05 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc. (343.33 KB, image/png)
2019-01-04 11:06 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-01-04 11:05:24 UTC
Description:
When an xlsx with a slicer gets opened in Calc it gets replaced with a text box that says slicers can only be used in Excel 2010 and newer versions.

Steps to Reproduce:
    1. Create a xlsx with some data.
    2. Create a pivot table with the data. Insert→ Pivot table.
    3. Create a slicer from the pivot table. Insert→ Slicer.
    4. Save as xlsx.
    5. Open in LO.

Actual Results:
All of the slicers got replaced with a text box saying the same thing.

Expected Results:
There should still be working slicers in LO.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-01-04 11:05:49 UTC
Created attachment 148019 [details]
A spreadsheet that contains slicers.
Comment 2 NISZ LibreOffice Team 2019-01-04 11:06:10 UTC
Created attachment 148020 [details]
Screenshot of the original document side by side in Excel and Calc.
Comment 3 Gabor Kelemen 2019-01-04 13:05:55 UTC

*** This bug has been marked as a duplicate of bug 119807 ***