Bug Hunting Session
Bug 122480 - UI: dialog Paragraph (Style) height is too large; it runs out of the screen( with asian and complex text layouts disabled )
Summary: UI: dialog Paragraph (Style) height is too large; it runs out of the screen( ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All Linux (All)
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords: bibisected, bisected, regression
: 122838 123286 123430 (view as bug list)
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2019-01-04 12:37 UTC by Cor Nouws
Modified: 2019-04-30 08:17 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
screen print dialog Paragraph Style runs off the screen (171.79 KB, image/png)
2019-01-04 12:37 UTC, Cor Nouws
Details
screen print of today (77.08 KB, image/png)
2019-01-16 08:26 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2019-01-04 12:37:59 UTC
Created attachment 148023 [details]
screen print dialog Paragraph Style runs off the screen

Writer document
context menu, Paragraph > Edit Style
notice that the dialog height is so much, that it runs of the screen at the bottom.

noticed in Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Cor Nouws 2019-01-04 12:38:43 UTC
was OK in 6.1.x > regression
Comment 2 Durgapriyanka 2019-01-04 23:09:52 UTC
Thank you for reporting the bug. I can not reproduce this bug in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-01-04 23:19:37 UTC
Hi Cor,
Does it happen with a specific document or with all?
Comment 4 Cor Nouws 2019-01-05 13:30:19 UTC
Hi Xisco,

(In reply to Xisco Faulí from comment #3)
> Does it happen with a specific document or with all?

With any,
Comment 5 Xisco Faulí 2019-01-15 22:13:58 UTC
Hi Cor,
Could you please try in safe mode?
OTOH, what happens if you run libreOffice with SAL_USE_VCLPLUGIN=gtk ?
Comment 6 Cor Nouws 2019-01-16 08:25:51 UTC
(In reply to Xisco Faulí from comment #5)
> Could you please try in safe mode?
How do I force that?

> OTOH, what happens if you run libreOffice with SAL_USE_VCLPLUGIN=gtk ?
Then I get the old gtk2 dialogs; normal height.

Maybe someone else can reproduce?
Comment 7 Cor Nouws 2019-01-16 08:26:36 UTC
Created attachment 148353 [details]
screen print of today
Comment 8 Xisco Faulí 2019-01-16 11:45:03 UTC
(In reply to Cor Nouws from comment #6)
> (In reply to Xisco Faulí from comment #5)
> > Could you please try in safe mode?
> How do I force that?

Go to Help - Restart in Safe mode...
Comment 9 Cor Nouws 2019-01-20 21:40:10 UTC
(In reply to Xisco Faulí from comment #8)

> Go to Help - Restart in Safe mode...
Not found in my Help..
Comment 10 Xisco Faulí 2019-01-21 10:35:41 UTC
(In reply to Cor Nouws from comment #9)
> (In reply to Xisco Faulí from comment #8)
> 
> > Go to Help - Restart in Safe mode...
> Not found in my Help..

Menu help - Restart in safe mode? that's weird. you can also launch LibreOffice with --safe-mode
Comment 11 Cor Nouws 2019-01-21 14:58:54 UTC
(In reply to Xisco Faulí from comment #10)
> (In reply to Cor Nouws from comment #9)
> > (In reply to Xisco Faulí from comment #8)
> > 
> > > Go to Help - Restart in Safe mode...
> > Not found in my Help..
> 
> Menu help - Restart in safe mode? that's weird. you can also launch
> LibreOffice with --safe-mode
With clean profile, tried various options. Each with the same result.

Output:
  $ ../libreofficedev6.3/program/soffice with --safe-mode
 
  (soffice:8899): GLib-GObject-CRITICAL **: 15:56:00.741: g_object_get_data: assertion 'G_IS_OBJECT (object)' failed
Gtk-Message: 15:56:00.748: GtkDialog mapped without a transient parent. This is discouraged.

Error popup:
  [  /home/cono/with doesn't exist ]
Comment 12 Xisco Faulí 2019-01-21 16:42:22 UTC
*** Bug 122838 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2019-01-21 16:56:05 UTC
Does it happen if you call LibreOffice with SAL_USE_VCLPLUGIN=gtk instdir/program/swriter ?
Which version of GTK do you have ?
Comment 14 Jim Avera 2019-01-21 18:30:47 UTC
> Does it happen if you call LibreOffice with SAL_USE_VCLPLUGIN=gtk 

No difference for me (the style dialog still open taller than the screen)
Comment 15 Jim Avera 2019-01-21 18:32:00 UTC
PLEASE IGNORE previous comment.  Wrong bug. (sorry)
Comment 16 Cor Nouws 2019-01-21 22:39:50 UTC
confirmed as per duplicate :)
Comment 17 Cor Nouws 2019-01-21 22:40:36 UTC
(still needed to be found out why of course..)
Comment 18 Xisco Faulí 2019-01-21 22:44:35 UTC
(In reply to Cor Nouws from comment #17)
> (still needed to be found out why of course..)

Please, share the gtk3 version
Comment 19 Jim Avera 2019-01-22 02:13:03 UTC
Confirming this bug on Ubuntu 18.04, LO 6.2.1.0.0 or later.
Does not happen with LO 6.1.3.2

Also: SAL_USE_VCLPLUGIN=gtk *does* make the bug go away.

STEPS TO REPRODUCE:
1. Start Writer
2. Styles->Edit Style... (opens Paragraph Style: dialog)
Comment 20 Jean-Baptiste Faure 2019-01-22 17:01:06 UTC
Reproducible for me in LO 6.2.1.0.0+ and LO 6.3.0.0.alpha0+, both built at home under Ubuntu 18.04 x86-64 and GTK3 backend.

Restarting with a clean new profile does not cure the problem.

Best regards. JBF
Comment 21 Jean-Baptiste Faure 2019-01-22 17:27:42 UTC
Workaround: activate Asian or Complex text layout under Tools > Options > Language Settings > Languages

Best regards. JBF
Comment 22 Xisco Faulí 2019-01-22 17:45:07 UTC
I can reproduce it in a virtual machine with Kubuntu 17.10 using GTK3 and asian complex text layout disabled... bisecting...
Comment 23 Xisco Faulí 2019-01-22 17:57:39 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b78edeca8631a5e3b888d6fb357fe9125a491c41

author	Caolán McNamara <caolanm@redhat.com>	2018-10-01 20:20:51 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-11-21 22:08:47 +0100
commit	b78edeca8631a5e3b888d6fb357fe9125a491c41 (patch)
tree	d2781b13339c9a7145aedd4aac7501ec0d208e3d
parent	47897fdd936d9b6e9ac8cb6110c79352ab080df7 (diff)
weld writer parastyle dialog

Bisected with: bibisect-linux64-6.3

Adding Cc: to Caolán McNamara
Comment 24 Commit Notification 2019-01-23 11:25:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/96da91726c498d0cab06e2df2932a90415e5c6cf%5E%21

Resolves: tdf#122480 make style dialogs take their optimal size

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Caolán McNamara 2019-01-23 11:49:56 UTC
fixed in master, backports in gerrit
Comment 26 Xisco Faulí 2019-01-23 13:29:47 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 0750be852e865c6c5f6f26365064126c10770f31
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, Thanks for fixing this!!
Comment 27 Commit Notification 2019-01-23 13:57:47 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/8013be56e6e661f6d17d9a2449b70096d2943f85%5E%21

Resolves: tdf#122480 make style dialogs take their optimal size

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Jean-Baptiste Faure 2019-01-23 15:19:32 UTC
Verified fixed in LO 6.2.1.0.0+ built at home under Ubuntu 18.04 x86-64.

Thank you very much for the quick fix.

Best regards. JBF
Comment 29 Xisco Faulí 2019-02-12 14:03:39 UTC
*** Bug 123286 has been marked as a duplicate of this bug. ***
Comment 30 Dieter Praas 2019-02-13 09:20:39 UTC
*** Bug 123430 has been marked as a duplicate of this bug. ***
Comment 31 Xisco Faulí 2019-03-21 16:44:49 UTC
*** Bug 124241 has been marked as a duplicate of this bug. ***