Download it now!
Bug 122486 - Table background color not changing
Summary: Table background color not changing
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2019-01-04 13:17 UTC by Telesto
Modified: 2019-01-17 18:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.06 KB, application/vnd.oasis.opendocument.text)
2019-01-04 13:17 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-01-04 13:17:26 UTC
Description:
Table background color not changing

Steps to Reproduce:
1. Open the attached file
2. Table -> Properties -> Background tab
3. Select Table (instead of cell)
4. Choose a color & press OK -> Nothing

Cause: cell based color is preferred above table row/color setting. Selecting a full table -> Choose background color from Background color picker in the toolbar will use Cell based formatting.

Not sure how things can be improved, but this can lead to confusion. 

Actual Results:
Nothing happens

Expected Results:
Not 100 sure
* Overwriting the cell based formatting  -> prefer by me (but looks like a hidden feature) 
* A warning-box that all cells have a direct formatting




Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 6e5c4001c7b5cab2b2cc6419072acbe5fa7cb04a
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2019-01-04 13:17:44 UTC
Created attachment 148028 [details]
Example file
Comment 2 MM 2019-01-04 15:22:44 UTC
Confirmed on mint 19.1 with Version: 6.3.0.0.alpha0+
Build ID: 43836a58ffe943e2fc65be638f9a7d343102cb07
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-12-29_04:29:11
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

If in step 3, you select 'row', it doesn't work also.
If you select the whole table prior to step 1 (selecting background tab / 'cell'), it works.
Comment 3 Xisco Faulí 2019-01-16 18:48:46 UTC
I don't think this is a bug. Cell background will predominates over the table background. Cell's background needs to be 'no fill' in order to see the table's background on that cell.
Closing as RESOLVED NOTABUG
Comment 4 Xisco Faulí 2019-01-16 18:50:42 UTC
(In reply to Telesto from comment #0)
> * A warning-box that all cells have a direct formatting

Regarding this point, if you have 300 cells with a cell background and you change the table background, would you show the warning 300 times? I don't think it's reasonable...
Comment 5 Xisco Faulí 2019-01-16 18:51:47 UTC
I let the UX team decide. I would say it's a WONTFIX as explained in comment 4
Comment 6 Heiko Tietze 2019-01-17 15:42:42 UTC
Would be reasonable and easier to understand when cell background overrules the table style similar to text where direct formatting overrides the style. So my take is to check the feasibility.
Comment 7 Telesto 2019-01-17 18:07:27 UTC
(In reply to Heiko Tietze from comment #6)
> Would be reasonable and easier to understand when cell background overrules
> the table style similar to text where direct formatting overrides the style.
> So my take is to check the feasibility.

I've changed my mind. Yes, table background color option not working because of the cell formatting is slightly confusing.. However overwriting all the cell-formatting isn't an option either.. The table color option rather practical with the proper workflow

So leaving this as it is seems reasonable..

RESOLVED -> NAB