Bug 122496 - Autofilter icon marked as filtered (there is a dot) when shows all rows
Summary: Autofilter icon marked as filtered (there is a dot) when shows all rows
Status: RESOLVED DUPLICATE of bug 122260
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2019-01-04 20:33 UTC by Roman Kuznetsov
Modified: 2019-02-06 18:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with autofilter (41.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-01-04 20:35 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-01-04 20:33:21 UTC
Description:
Autofilter icon marked as filtered (there is a dot) when shows all rows.
All cells have hyperlinks.
If cells don't have hyperlinks then icon of Autofilter works fine.

Version: 6.3.0.0.alpha0+
Build ID: 9c9558bf9151bff50735b1ca61d2d3de881b24ce
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL
Build from 02-January-2019

Steps to Reproduce:
1. Open file from attach
2. Try use Autofilter in column B, make some filtrations
3. After check option "All" you'll see all rows
4. But icon of Autofilter in B1 have a dot like as there is a filter

Actual Results:
icon of Autofilter in B1 have a dot like as there is a filter

Expected Results:
icon of Autofilter in B1 doesn't have a dot like as there is a filter


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-01-04 20:35:03 UTC
Created attachment 148048 [details]
Example file with autofilter
Comment 2 Roman Kuznetsov 2019-01-04 20:37:22 UTC
in

Version: 6.0.3.2
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: ru-RU (ru_RU); Calc: CL

icon works as expected -> regression
Comment 3 Durgapriyanka 2019-01-04 21:33:02 UTC
Thank you for reporting the bug. I can confirm that the bug is present in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Roman Kuznetsov 2019-01-05 14:44:42 UTC
I bisected it

$ git bisect bad
f0e785a719563e5dda2b81ac6ed33e27ba3a1055 is the first bad commit
commit f0e785a719563e5dda2b81ac6ed33e27ba3a1055
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Tue Jun 12 08:41:15 2018 -0700

    source sha:c8a739a2c84f45f878d2ae75eaf16a2f814d1c6e

https://gerrit.libreoffice.org/#/c/55436/

CC: Serge Krot
Comment 5 Xisco Faulí 2019-02-06 18:50:08 UTC
No longer reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 202d9af5ab4291a8f867791293477a18ae48051d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

This is a duplicate of bug 122260

*** This bug has been marked as a duplicate of bug 122260 ***