Bug 122508 - Implement whole page background image
Summary: Implement whole page background image
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords:
: 125713 (view as bug list)
Depends on:
Blocks: Object-Fill Page-Style-Dialog
  Show dependency treegraph
 
Reported: 2019-01-05 13:24 UTC by juh+bugzilla-documentfoundation
Modified: 2021-07-23 13:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description juh+bugzilla-documentfoundation 2019-01-05 13:24:33 UTC
Description:
https://bugs.documentfoundation.org/show_bug.cgi?id=112195 was closed but without the whole solution.

Actual Results:
It is not possible to have a fullpage image as background

Expected Results:
Having a full page image as background of the whole page


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 raal 2019-01-05 20:28:45 UTC
Setting to new, https://bugs.documentfoundation.org/show_bug.cgi?id=112195#c17
Comment 2 Dieter 2019-06-05 15:47:10 UTC
*** Bug 125713 has been marked as a duplicate of this bug. ***
Comment 3 Mike Kaganski 2019-07-22 08:44:18 UTC
Just a note: it's possible, but only in tiled mode, possibly requires setting proper image width and height (so that it fits once in both directions). In "Custom position/size" and "Stretched" modes, the image still only fills inside margins.
Comment 4 Leandro Martín Drudi 2019-08-24 21:52:48 UTC
Reproducible in:
Versión: 6.3.0.4 (x64)
Id. de compilación: 057fc023c990d676a43019934386b85b21a9ee99
Subprocs. CPU: 8; SO: Windows 10.0; Repres. IU: predet.; VCL: win; 
Configuración regional: es-AR (es_AR); Idioma de IU: es-ES
Calc: CL
Comment 5 Commit Notification 2021-03-25 08:50:52 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/56d8007a197b095b09423c691a51515567648e80

tdf#134734 tdf#141059 tdf#122508 cui,sw,xmloff: BackgroundFullSize

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 stragu 2021-07-23 13:03:56 UTC
This has been fixed by the commit above (available in LO 7.2 and 7.3).

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: cd2b5168e8ef1cb6e721bc5220421464ed723096
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-07-21_14:56:23
Calc: threaded

Version: 7.2.0.1 / LibreOffice Community
Build ID: 32efc3b7f3a71cfa6a7fa3f6c208333df48656cc
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded