Bug 122517 - LO writer only web styles and char properties available with right-clic
Summary: LO writer only web styles and char properties available with right-clic
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2019-01-06 16:23 UTC by Thierry Seewald
Modified: 2019-01-07 20:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Printscreen (132.79 KB, image/png)
2019-01-07 12:15 UTC, Thierry Seewald
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Seewald 2019-01-06 16:23:18 UTC
Description:
Hi,
When I make a right-clic in a writer text (whatever text, old or new), I don't have the stadard menu, but a menu related to HTML, i.e. for paragraph, I have a submenu linked to web items (body, head 1, head 2...) and not a paragraph menu-window, for char I have a submenu (and not a char menu-window), with only web char items.
It is as if I was in a web mode, but I am in the standard page mode.
I have tried the safe mode (with various options), I have uninstalled et reinstalled, erased the directories, I always have a web menu.
All other menus are allright, with all features, it's only the right-clic menu.

Steps to Reproduce:
1. Right-clic in a page
2. clic on paragraph
3.

Actual Results:
a submenu opens on the right with only web paragraph options

Expected Results:
A window should open with paragraph options


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-01-07 11:40:51 UTC
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 Thierry Seewald 2019-01-07 11:48:11 UTC
I have reset everything, including the user profile,
the bug is still there.
Comment 3 Thierry Seewald 2019-01-07 12:15:56 UTC
Created attachment 148095 [details]
Printscreen
Comment 4 Thierry Seewald 2019-01-07 12:17:34 UTC
I have uninstalled LO 6.2.0.1
and reinstalled LO 6.1.4.2
and the pb disappeared
reinstalled LO 6.2.0.1
the pb reappeard.

but I'm sure it was not the was after the first LO 6.2.0.1 installation, son I don't think it's a new feature.

I have send a printscreen (in french), so you can see what I mean and can confirm if it's regular or not.
Comment 5 Thierry Seewald 2019-01-07 14:31:58 UTC
I have uninstalled LO 6.2.0.1
and reinstalled LO 6.1.4.2
and the pb disappeared
reinstalled LO 6.2.0.1
the pb reappeared.

but I'm sure it was not the case after the first LO 6.2.0.1 installation, so I don't think it's a new feature.

I have send a printscreen (in french), so you can see what I mean and can confirm if it's regular or not.
Comment 6 andreas_k 2019-01-07 20:17:16 UTC
Hi,

what's the bug?

The context menu (right click) get an update with 6.2. The paragraph dialog is available in right-clic -> paragraph -> Paragraph ...
Comment 7 Thierry Seewald 2019-01-07 20:19:53 UTC
the enhancement did not appear in the release notes, with what you say, there is  no bug
Comment 8 Dieter 2019-01-07 20:21:23 UTC
(In reply to andreas_k from comment #6)

> The context menu (right click) get an update with 6.2. 

I thought of this, but I couldn't find it in the release notes. So, since it works as expected, I think we can close this report as NOTABUG. Thierry, if you don't agree, please feel free to change it back to UNCONFIRMED with a short reasoning.