Download it now!
Bug 122527 - Dot symbols in Calc Charts other than the squares are not available
Summary: Dot symbols in Calc Charts other than the squares are not available
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2019-01-07 11:07 UTC by Andy
Modified: 2019-01-24 13:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
This is previous versions correct choice list (31.10 KB, image/png)
2019-01-07 11:09 UTC, Andy
Details
This is the wrong list in LO6.2.0.1 (45.07 KB, image/png)
2019-01-07 11:10 UTC, Andy
Details
How the fix looks in gtk 3.18.9 (130.91 KB, image/png)
2019-01-09 09:45 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2019-01-07 11:07:47 UTC
Description:
Normally, when creating a dispersion chart in Calc, square points are created by default but you can change them to a variety of other shapes with the appropriate dialog window. In LO 6.2.0.1 this is not possible and the list of dot shapes is wrongly filled with a list of identical squares for all options, with a "foo" puzzling test label always associated to each of them

Steps to Reproduce:
1. Open a Calc sheet and insert in column A and B any numbers for a few cells (say for 10 cells)
2. Now select the data and create a dispersion chart for them, choosing the appropriate type of chart.
3. Choose the sub-types with dots only or line+dots for the chart
4. by default points in the graph have a (rather large) square shape. 
5. Select the data points, and with the associated format dialog window go to the "line" tab and try changing the "Icon" properties (This is "Icona" in Italian, I cannot be sure the English rendition is "Icon", but is the item on the right side of the dialog window): click on the "select" button and choose the "symbols" item in the menu
6: the choice list you obtain has a dozen items, all identical, with square shape and "foo" labels. So you cannot assign any other shape to the data points.

Actual Results:
In a dispersion chart, points are forced to a have a square shape with no alternatives available

Expected Results:
You should get the item list available until 6.1.4, with a dozen different shapes to choose among. See the attached pictures to see what's happening.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Andy 2019-01-07 11:09:40 UTC
Created attachment 148092 [details]
This is previous versions correct choice list
Comment 2 Andy 2019-01-07 11:10:08 UTC
Created attachment 148093 [details]
This is the wrong list in LO6.2.0.1
Comment 3 Xisco Faulí 2019-01-07 23:28:03 UTC
The Symbols entry in the dropdown list disappeared in https://cgit.freedesktop.org/libreoffice/core/commit/?id=0d1df8d5ea2ee25903044d7cb72d00a721a1b902 and then was reintroduced in https://cgit.freedesktop.org/libreoffice/core/commit/?id=0895c26b7761215e92eef7b3fbf384982ac01eeb were the problem is already reproducible...

Adding Cc: to Caolán McNamara
Comment 4 Commit Notification 2019-01-08 21:02:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08%5E%21

tdf#122527 dot symbols in chart menubutton not working

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2019-01-08 21:03:07 UTC
backport in gerrit, fixed in master
Comment 6 Xisco Faulí 2019-01-09 09:44:37 UTC
I do confirm the issue is fixed in

Version: 6.3.0.0.alpha0+
Build ID: 54515a6a01a372729bf8a7f9e992c51f214ec9a6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and gen, but the symbols are not displayed in gtk3 ( maybe gtk 3.18 ?? )
Comment 7 Xisco Faulí 2019-01-09 09:45:06 UTC
Created attachment 148162 [details]
How the fix looks in gtk 3.18.9
Comment 8 Caolán McNamara 2019-01-09 11:37:03 UTC
wrt gtk 3.18, I hope https://gerrit.libreoffice.org/#/c/66013/ addresses that extra problem
Comment 9 Commit Notification 2019-01-09 21:12:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/08be15ebedd173dbc86fbbdf33667d7fa45ec1bc%5E%21

tdf#122527 dot symbols in chart menubutton not working

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-01-09 21:12:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f22f28e722a8a2efdc42bddba80a3a43025a61fd%5E%21

Related: tdf#122527 gtk < 3.20 and gtk_image_new_from_surface

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2019-01-09 23:25:04 UTC
Gtk3 fixed verified in

Version: 6.3.0.0.alpha0+
Build ID: 4f846cbc5ab3089648d36f2ba03b980cf7e31c0e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for the quick fix!!
Comment 12 Commit Notification 2019-01-10 08:56:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1324a878d6821c380c39c311fcded5976174d5fd%5E%21

Related: tdf#122527 gtk < 3.20 and gtk_image_new_from_surface

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.