Download it now!
Bug 122534 - Changes not noticed and "Manage Changes" window doesn't appear after comparing documents with header/footer removed
Summary: Changes not noticed and "Manage Changes" window doesn't appear after comparin...
Status: RESOLVED DUPLICATE of bug 71152
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2019-01-07 15:49 UTC by Dmitry
Modified: 2019-01-07 17:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Changed document (86.45 KB, application/vnd.oasis.opendocument.text)
2019-01-07 16:05 UTC, Dmitry
Details
Source document (86.72 KB, application/vnd.oasis.opendocument.text)
2019-01-07 16:09 UTC, Dmitry
Details
Smaller test source ODT (8.90 KB, application/3dr)
2019-01-07 17:18 UTC, Timur
Details
Smaller test changed ODT (8.85 KB, application/3dr)
2019-01-07 17:19 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2019-01-07 15:49:02 UTC
Description:
After comparing documents with tables that consist of 300 and
more pages, "Manage Changes" window doesn't appear

Steps to Reproduce:
1. Open changed document.
2. Edit -> Track Changes -> Compare document...
3. Choose source document in "Compare to" window

Actual Results:
"Manage changes" window doesn't open, tracking changes is not done

Expected Results:
Opening "Manage changes" window


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.3.2
Build ID: 1:6.1.3~rc2-0ubuntu0.18.04.2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 1 Dmitry 2019-01-07 16:05:50 UTC
Created attachment 148100 [details]
Changed document
Comment 2 Dmitry 2019-01-07 16:09:05 UTC
Created attachment 148102 [details]
Source document
Comment 3 Durgapriyanka 2019-01-07 16:22:27 UTC
Thank you for reporting the bug. I can not reproduce this bug in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Dmitry 2019-01-07 16:38:40 UTC Comment hidden (obsolete)
Comment 5 Durgapriyanka 2019-01-07 16:55:53 UTC
(In reply to Dmitry from comment #4)
> Do you have the window "manage changes" when comparing attachment 1 to
> attachment 2?

Yes, "Manage changes" window opens up immediately once I enter the name of the file to compare.
Comment 6 Timur 2019-01-07 17:17:29 UTC
Interesting. I do repro with LO 6.3+ in Windows 7.
MSO shows 20 revisions, 18 formats (which is Bug 50447) and 2 deletions (header and footer). 
But:
- "Manage Changes" window doesn't appear because changes are not noticed,
- it's not about "big document", it's about change in header/footer.
Comment 7 Timur 2019-01-07 17:18:38 UTC
Created attachment 148107 [details]
Smaller test source ODT
Comment 8 Timur 2019-01-07 17:19:34 UTC
Created attachment 148108 [details]
Smaller test changed ODT

Change here is that header is removed (this bug) and text was formatted to bold (other bug).
Comment 9 Timur 2019-01-07 17:36:14 UTC
Surprise, surprise. 
This looks like a duplicate of Bug 71152 for header/footer and of Bug 50447 for formats.

*** This bug has been marked as a duplicate of bug 71152 ***