Download it now!
Bug 122536 - SVG icons do not look good on 4K HiDPI display on Linux
Summary: SVG icons do not look good on 4K HiDPI display on Linux
Status: RESOLVED DUPLICATE of bug 115439
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2019-01-07 16:15 UTC by Frederic Parrenin
Modified: 2019-02-15 14:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
.png screenshot showing the strange SVG icons (224.54 KB, image/png)
2019-01-07 16:15 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2019-01-07 16:15:02 UTC
Created attachment 148103 [details]
.png screenshot showing the strange SVG icons

I have a debian 10 machine with a 4k HiDPI display.
I installed LO 6.2.0 in the hope that the SVG icons would look more crisp that the traditional png icons on this 4k display.
But actually, this is not the case.
The icons do not look more crisp, and moreover they do not look the same at all: fonts and lines look thinner.
I attach a screenshot with the elementary icon set.
Comment 1 Regina Henschel 2019-01-07 23:11:03 UTC
The user directory has a folder "cache" and therein a folder with the name of the icon-theme. It contains the png-images, which are generated according to your monitor resolution. It is not automatically rebuild, in case you install a new version. Please close LibreOffice, delete this folder, and start LibreOffice/Writer again. Doing so will rebuild the icon-theme cache. Does that solve the problem?
Comment 2 Frederic Parrenin 2019-01-08 09:22:11 UTC
I tried to remove the cache folder but it does not change anything.
Comment 3 Regina Henschel 2019-01-08 13:20:41 UTC
We need someone with similar hardware to confirm it.
Comment 4 V Stuart Foote 2019-02-15 13:32:08 UTC

*** This bug has been marked as a duplicate of bug 115439 ***
Comment 5 Frederic Parrenin 2019-02-15 13:54:49 UTC
I do not think this bug is a duplicate of 115439.
115439 says that SVG icons should be used by default.
This bug says that, even with SVG, icons do not look crisp on 4k displays.
Comment 6 V Stuart Foote 2019-02-15 14:23:18 UTC
(In reply to Frederic Parrenin from comment #5)
> I do not think this bug is a duplicate of 115439.
> 115439 says that SVG icons should be used by default.
> This bug says that, even with SVG, icons do not look crisp on 4k displays.

Issue in bug 115439 is that we do not use the SVG directly for icons--that is what needs additional work. Instead, we scale the SVG (or PNG) and write that to user profile cache of scaled PNG, and that is used in the GUI.
Comment 7 Frederic Parrenin 2019-02-15 14:24:42 UTC
OK, understood.