Bug 122551 - Information reported under Chapter Numbering is by default the one related to the last applied numbering settings regardless the selected Heading's expression in document.
Summary: Information reported under Chapter Numbering is by default the one related to...
Status: RESOLVED DUPLICATE of bug 115104
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering-Dialog
  Show dependency treegraph
 
Reported: 2019-01-07 20:52 UTC by ricky.tigg
Modified: 2019-01-08 09:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (60.17 KB, image/jpeg)
2019-01-08 09:15 UTC, Dieter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ricky.tigg 2019-01-07 20:52:09 UTC
Description:
When selecting an Heading's expression in document to which some Chapter Numbering settings have been applied, information then reported under Chapter Numbering is by default the one related to the last applied numbering settings regardless the selected expression.

Steps to Reproduce:
1. Open a new ODT document;
2. Enter a two-lined content as follow:
A
B
3. Apply styles Heading 1, Heading 2 respectively to expressions A, B;
4. Under Tools => Chapter Numbering..., under Numbering tab, apply in that order Level 1, Level 2 respectively to styles Heading 1, Heading 2;
5. Select the content to which style Heading 1 is applied then open Tools => Chapter Numbering..., Numbering tab.
 

Actual Results:
5. – Information reported is related to the last applied numbering settings in document – here Level 2 –.

Expected Results:
5. – Information to match numbering settings applied – here Level 1 – to currently selected heading's expression.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.1.2.1; Build ID: 6.1.2.1-4.fc29; CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; Locale: en-GB (en_GB.UTF-8); Calc: group threaded
Comment 1 Dieter 2019-01-08 09:15:03 UTC
Created attachment 148127 [details]
Screenshot

I confirm it with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 2 Dieter 2019-01-08 09:17:24 UTC

*** This bug has been marked as a duplicate of bug 115104 ***