Bug 122594 - FILEOPEN/FILESAVE DOCX LibreOffice Writer always shows the first sheet of the OLE embedded XLSX spreadsheet
Summary: FILEOPEN/FILESAVE DOCX LibreOffice Writer always shows the first sheet of the...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-OLE-Objects
  Show dependency treegraph
 
Reported: 2019-01-09 10:14 UTC by NISZ LibreOffice Team
Modified: 2019-02-19 00:22 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot showcasing the issue. (103.79 KB, image/png)
2019-01-09 10:14 UTC, NISZ LibreOffice Team
Details
The original document. (32.52 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-09 10:15 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-01-09 10:14:00 UTC
Description:
LibreOffice Writer always shows the first sheet of the OLE embedded XLSX spreadsheet in Microsoft Word saved DOCX documents, regardless of which one was originally chosen.

Steps to Reproduce:
     reate a new spreadsheet in Microsoft Excel with multiple worksheets and save the file with an active worksheet different from the first one.
    2. Create a new document in Microsoft Word and insert the newly created XLSX file as OLE object. Make sure that the active worksheet is not the first one.
    3. Save the file as DOCX.
    4. Open the file both in LibreOffice Writer and Microsoft Word and compare them.

Actual Results:
LibreOffice writer will show the first worksheet of the embedded XLSX file, while Microsoft Word will show the one that was originally selected.

Expected Results:
Both LibreOffice Writer and Microsoft Word should show the same worksheet of the OLE embedded XLSX file.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-01-09 10:14:40 UTC
Created attachment 148163 [details]
A screenshot showcasing the issue.
Comment 2 NISZ LibreOffice Team 2019-01-09 10:15:03 UTC
Created attachment 148164 [details]
The original document.
Comment 3 Cor Nouws 2019-01-09 11:21:55 UTC
confirming in Version: 6.3.0.0.alpha0+
Build ID: 3bf82348bc73797fec61997dc4268a322299b3ff
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-06_08:29:45
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded


was OK in Versie: 5.4.1.2 
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU-threads: 4; Besturingssysteem:Linux 4.15; UI-render: standaard; VCL: gtk2; 
Locale: nl-NL (nl_NL.UTF-8); Calc: group

 > regression

(6.2.0.1 and 6.0.7.2 show Sheet1 too, and also in a wrong scaling)
Comment 4 raal 2019-01-09 17:29:52 UTC
This seems to have begun at the below commit.
Adding Cc: to Szymon Kłos; Could you possibly take a look at this one? Thanks

3e092e207e04ea141c59d25e8c71b1c74e2e1cfe is the first bad commit
commit 3e092e207e04ea141c59d25e8c71b1c74e2e1cfe
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Jul 29 06:24:35 2017 -0700

    source sha:505ce3a2ba3adeef46daecbf9b14c42cea211408

author	Szymon Kłos <szymon.klos@collabora.com>	2017-07-07 12:58:42 +0200
committer	Szymon Kłos <szymon.klos@collabora.com>	2017-07-08 09:28:09 +0200
commit	505ce3a2ba3adeef46daecbf9b14c42cea211408 (patch)
tree	aab90b60e9c0c0ac5b7ea912dc3b25a8c45614cf
parent	3340ce30562832b584dd0576d9e0733aa03d867f (diff)
tdf#108544 edit in window (XLSX inside DOCX)
Comment 5 Xisco Faulí 2019-01-10 12:27:54 UTC
*** Bug 122624 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2019-02-07 20:05:14 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/70ab6ff7c22ce850c9041bfeeeaba7038011a0a7%5E%21

tdf#122594 OLE import in DOCX: show selected sheet

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-02-12 15:46:47 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b3d88a0875efcbc3efcabeef743ff0dc4d8cf686%5E%21

tdf#122594 XLSX OLE in DOCX: export ActiveTable

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2019-02-13 11:07:51 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 6d52cd1c0b7270a512a8e4ea988432fdad3e4385
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@László Németh, thanks for fixing this!!
Comment 9 László Németh 2019-02-19 00:22:04 UTC
@Xisco: thanks for your feedback!