Bug Hunting Session
Bug 122597 - CRASH: all chart dialogs crash if LibreOffice is closed while they are open (gen/gtk2)
Summary: CRASH: all chart dialogs crash if LibreOffice is closed while they are open (...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0
Keywords: bibisected, bisected, regression
: 122510 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-09 11:23 UTC by Xisco Faulí
Modified: 2019-01-11 16:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-01-09 11:23:22 UTC
Steps to reproduce:
1. Open Writer
2. Insert a chart
3. Double on the legends or x-axis or y-axis or bars, etc, etc
4. Close LibreOffice
-> Crash

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 54515a6a01a372729bf8a7f9e992c51f214ec9a6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

gtk3 doesn't allow to close LibreOffice while the dialogs are open...
Comment 1 Xisco Faulí 2019-01-09 11:26:00 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4d83c24cdd433d5c63800290e2da6317ae12111c

author	Caolán McNamara <caolanm@redhat.com>	2018-11-02 18:21:20 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-11-04 17:33:06 +0100
commit	4d83c24cdd433d5c63800290e2da6317ae12111c (patch)
tree	bfd4c863f0f79d40ac1671812fef1976ca4a9c85
parent	628e96ce1fce194b30a5c2912feb8b7ec0328db0 (diff)
reweld SwWordCountFloatDlg
fixing up the bit that failed the last time

Bisected with: bibisect-linux64-6.2

Adding Cc: to Caolán McNamara
Comment 2 Commit Notification 2019-01-09 14:10:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4c89c6c7c1bd89cda5690ae620092e3b32b11d97%5E%21

Resolves: tdf#122597 chart dialog should be modal

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Caolán McNamara 2019-01-09 14:11:34 UTC
backport to 6-2 in gerrit, fixed in master
Comment 4 Caolán McNamara 2019-01-09 14:31:53 UTC
*** Bug 122510 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2019-01-09 18:47:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/49e22dbd36fefdb32f929a87a961f821444df96c%5E%21

Resolves: tdf#122597 chart dialog should be modal

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-01-09 23:22:46 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 4f846cbc5ab3089648d36f2ba03b980cf7e31c0e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Cherry-picked to 6-2-0 -> https://gerrit.libreoffice.org/#/c/66056/
Comment 7 Commit Notification 2019-01-10 15:07:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-0":

https://git.libreoffice.org/core/+/8c4e0b2fcf4ab407b4a625353353f8a2840d91c3%5E%21

Resolves: tdf#122597 chart dialog should be modal

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.