Download it now!
Bug 122602 - Insert -> Text from File... should import more than one file at a time
Summary: Insert -> Text from File... should import more than one file at a time
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Insert-File-Content
  Show dependency treegraph
 
Reported: 2019-01-09 13:12 UTC by Daniel Grigoras
Modified: 2019-01-10 16:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Grigoras 2019-01-09 13:12:52 UTC
Description:
Insert -> Text from File... offers support for importing only one file at a time. This is not efficient at all if one wants to import the contents of 70 files, as in my case.
Please enhance this feature for content insertion from multiple files.

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2019-01-09 15:12:04 UTC
Feasible, but personally I would merge the text files external to Writer and then import. 

And, a non-starter for import to Calc, where even as text--field formatting must be handled.
Comment 2 Daniel Grigoras 2019-01-09 17:55:49 UTC
(In reply to V Stuart Foote from comment #1)
> Feasible, but personally I would merge the text files external to Writer and
> then import. 

How can ODTs be merged, because that's what I actually want to do?
Comment 3 V Stuart Foote 2019-01-09 19:30:58 UTC
A bit convoluted but currently the File -> New -> Master Document will let you insert and bring in multiple documents. Then save Contents. Finally File -> Export: "ODF Text document"

You can then Save As flat ODF, and from there remove the file linkages with a text editor.

But, would be cleaner if the Insert dialog handling and filter did facilitate multiple source texts for the simple Insert -> Text from File
Comment 4 Daniel Grigoras 2019-01-09 21:00:35 UTC
(In reply to V Stuart Foote from comment #3)

Ah, that I knew and that's what I was planning to do. I thought there was an easier way.
Comment 5 Heiko Tietze 2019-01-10 10:53:04 UTC
(In reply to Daniel Grigoras from comment #4)
> (In reply to V Stuart Foote from comment #3)
> 
> Ah, that I knew and that's what I was planning to do. I thought there was an
> easier way.

So do you agree with WORKSFORME? Multiselection leads to sorting problems, you never know what item comes first (actually it depends on OS and the sequence you select items). And with simplicity in mind the Insert File function should be used for only a limited use case.
Comment 6 Daniel Grigoras 2019-01-10 12:50:02 UTC
This cannot be closed as WORKSFORME, but only as WORKSFORME (in another way or a different tool).
Support for inserting text from multiple files should be added via Insert -> Text from File...
Master documents have a different purpose.