Bug Hunting Session
Bug 122608 - Fileopen DOCX: Table shown as text
Summary: Fileopen DOCX: Table shown as text
Status: RESOLVED DUPLICATE of bug 116194
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-01-09 16:58 UTC by Laurent Bigonville
Modified: 2019-01-10 18:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
.docx file (25.60 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-09 16:58 UTC, Laurent Bigonville
Details
.pdf file (243.74 KB, application/pdf)
2019-01-09 17:00 UTC, Laurent Bigonville
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Bigonville 2019-01-09 16:58:20 UTC
Created attachment 148176 [details]
.docx file

Hello,

The attached .docx document is really badly rendered especially the 1st part that is made of different frame/boxes
Comment 1 Laurent Bigonville 2019-01-09 17:00:03 UTC
Created attachment 148177 [details]
.pdf file

How it should look like
Comment 2 Durgapriyanka 2019-01-09 17:37:50 UTC
Thank you for reporting the bug. I can confirm this in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 Timur 2019-01-09 18:05:42 UTC
Thank you, but "Wrong rendering of docx document" title is a classic example of wrong bug report and confirmation.
Bugzilla is not "document based", like "this document doesn't display nice". 
Bugzilla is "issue based", so a single issue must be pointed at, after a search for not being a duplicate. 
Durgapriyanka, please define the issue and test previous versions. If not, rather just confirm in comment, without changing to New. Because it's not triaged and therefore there's no use of being confirmed. 

I'll change to "DOCX Table shown as text". 
Fine looking table "Informations utiles" was there with LO 4.2 and not with LO 4.3.
Looks like a regression to me. 
..which all makes it a probable duplicate of Bug 116194.
I guess bibisectRequest would show the same commit.

*** This bug has been marked as a duplicate of bug 116194 ***
Comment 4 Buovjaga 2019-01-09 19:50:53 UTC
(In reply to Timur from comment #3)
> Durgapriyanka, please define the issue and test previous versions. If not,
> rather just confirm in comment, without changing to New. Because it's not
> triaged and therefore there's no use of being confirmed. 

Timur: I get your intention, but this is not how we work. We have discussed this topic ("needsTriage") for hours on various occasions and I believe you were present in the Brno meeting in 2016 where it was first brought up. In the last QA meeting we *again* decided to not change anything:
https://dev-downloads.libreoffice.org/meetbot/libreoffice-qa/2018/libreoffice-qa.2018-11-28-15.01.log.html

I said: "if we decide not to add anything, we can add some clear guidelines in the wiki on what to search for, if concerned about these matters"

Xisco agreed and added the wiki task to his todo.
Comment 5 Buovjaga 2019-01-10 18:31:16 UTC
I confirm the same commit is responsible for this as bug 116194 (looked with 43max on Linux).