Download it now!
Bug 122609 - Send as PDF creates distorted or missing graphics with certain types of JPGs
Summary: Send as PDF creates distorted or missing graphics with certain types of JPGs
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2019-01-09 17:34 UTC by Data Pro
Modified: 2019-02-08 15:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF graphic failure (132.04 KB, application/pdf)
2019-01-09 17:37 UTC, Data Pro
Details
Picture used in doc (59.43 KB, image/jpeg)
2019-02-07 21:03 UTC, Data Pro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Data Pro 2019-01-09 17:34:39 UTC
Description:
Some graphics appear as triple overlay image or are just missing the graphics.  Have been working on the issue for years and various versions of LibreOffice.  Tried many different sources of images.  Current work around is to print via Cute PDF, but some clients want the function of Send as PDF for simplicity.

Steps to Reproduce:
1.Insert a graphic (typically JPG) into writer.
2.File > Send > E-mail as PDF 
3.Opens in mail clients (emClient/Mailbird/Live Mail 2012/Outlook) doesn't matter
4.Person receives e-mail as PDF with graphics issue.
5.Can also produce File > Export > Export as PDF.

Actual Results:
Distorted or missing graphics in PDF.  Several computers for different clients have been used with many combinations of software (email client, antivirus, and LibreOffice version).

Expected Results:
Graphics appear in color as they look in Writer document.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Data Pro 2019-01-09 17:37:20 UTC
Created attachment 148178 [details]
PDF graphic failure
Comment 2 Data Pro 2019-01-09 17:38:31 UTC
I have a version 6.0.1.1 that does work with my graphics, but not with the clients that I have submitted as attachment.
Comment 3 Durgapriyanka 2019-01-09 19:11:15 UTC
Thank you for reporting the bug. I can not confirm this in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Cor Nouws 2019-01-09 20:26:09 UTC
(In reply to Data Pro from comment #2)
> I have a version 6.0.1.1 that does work with my graphics, but not with the
> clients that I have submitted as attachment.

Looks as a bug on clients side.
Your PDF opens fine for me..

I would say: NotOurBug
Comment 5 Data Pro 2019-01-11 16:13:01 UTC
Can you send me a jpg screen capture of your results?  We are using Edge and Adobe Acrobat Reader DC 2019 to view the PDFs.  The specific PDF I uploaded is one that differs from one reader to another, but never appears correct.
Comment 6 Buovjaga 2019-01-26 15:13:47 UTC
(In reply to Cor Nouws from comment #4)
> (In reply to Data Pro from comment #2)
> > I have a version 6.0.1.1 that does work with my graphics, but not with the
> > clients that I have submitted as attachment.
> 
> Looks as a bug on clients side.
> Your PDF opens fine for me..
> 
> I would say: NotOurBug

Not true: the image appears incorrectly in Okular and Adobe Reader. Firefox shows it correctly.

However, Data Pro: please attach the original painting image, so we can inspect it and test with it. I assume there is something funky in the image.

Please attach an example document.
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the image.
Comment 7 Data Pro 2019-02-07 21:03:01 UTC
Created attachment 148998 [details]
Picture used in doc
Comment 8 Buovjaga 2019-02-08 08:22:16 UTC
Running "file Logo.jpg" I get:

Logo.jpg: JPEG image data, Exif standard: [TIFF image data, little-endian, direntries=14, height=675, bps=182, compression=none, PhotometricIntepretation=CMYK, orientation=upper-left, width=1125], baseline, precision 8, 747x675, components 4

Maybe the problem is the CMYK?

I will test export with different LibreOffice versions later.
Comment 9 Buovjaga 2019-02-08 15:39:07 UTC
Good news: I can still repro with 6.2.0, but the problem is gone in 6.3.0!

Data Pro can confirm the fix by installing a master version (it installs in parallel): https://dev-builds.libreoffice.org/daily/master/?C=M&O=D

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 573a473275ad7c76d0cada9b7e73d4923e7a79d5
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-02-03_01:22:10
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 5408f0731b9cd8be0e1b7aa5145b825337baad84
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 5 February 2019