Bug 122637 - Explain in the style dialog that Outline & Numbering options are disabled due to style being assigned to Chapter Numbering
Summary: Explain in the style dialog that Outline & Numbering options are disabled due...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.3.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicUI
Depends on:
Blocks: Chapter-Numbering
  Show dependency treegraph
 
Reported: 2019-01-10 14:30 UTC by ricky.tigg
Modified: 2019-01-18 17:13 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ricky.tigg 2019-01-10 14:30:04 UTC
Description:
Settings present under sections Outline, Numbering are not usable.

Steps to Reproduce:
1. Select from style panel Heading 1, right-click it, select Modify...;
2. Open Outline & Numbering tab.

Actual Results:
Settings present under sections Outline, Numbering are not usable while those present under section Line Numbering are.

Expected Results:
Settings under the sections Outline, Numbering to be usable.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.1.2.1; Build ID: 6.1.2.1-4.fc29; CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; Locale: en-GB (en_GB.UTF-8); Calc: group threaded
Comment 1 Durgapriyanka 2019-01-10 17:27:26 UTC
Thank you for reporting the bug. I can confirm the bug in  

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Oliver Brinzing 2019-01-12 16:02:51 UTC
i think the root cause why this option is disabled is:
"Heading 1" - "Heading 10" are used for Chapter Numbering.

Tools/Chapter Numbering...
- Level 1, replace "Heading 1" with "Caption"
- [OK]
- now "Heading 1" Outline Level should be editable
Comment 3 Buovjaga 2019-01-15 15:47:10 UTC
(In reply to Oliver Brinzing from comment #2)
> i think the root cause why this option is disabled is:
> "Heading 1" - "Heading 10" are used for Chapter Numbering.
> 
> Tools/Chapter Numbering...
> - Level 1, replace "Heading 1" with "Caption"
> - [OK]
> - now "Heading 1" Outline Level should be editable

True, so it is not a bug. I wonder, if there should be something in the dialog explaining, why the options are disabled. Let's ask UX team.
Comment 4 Roman Kuznetsov 2019-01-16 17:58:42 UTC
Default Header styles are built-in styles in LibreOffice, and Outline for it just is hardcoded.
You can create a New style from Header 1 and you'll can change Outline as you want

IMHO-> NOTABUG/WONTFIX
Comment 5 Cor Nouws 2019-01-17 13:45:35 UTC
(In reply to Roman Kuznetsov from comment #4)
> Default Header styles are built-in styles in LibreOffice, and Outline for it
> just is hardcoded.
> You can create a New style from Header 1 and you'll can change Outline as
> you want
> 
> IMHO-> NOTABUG/WONTFIX
I agree on that, but that is different from the question if some hint in the mentioned situation is useful?
Comment 6 Heiko Tietze 2019-01-17 14:47:18 UTC
We discussed the ticket in the design meeting and agree with the static text idea. It could be "Disabled unless Tools > Chapter Numbering: Paragraph Style is set to None" or "Disabled if the Paragraph Style is linked with Tools > Chapter Numbering" next to the section title "Outline". The static text is ideally hidden when the fields are enabled.
Comment 7 Heiko Tietze 2019-01-17 16:12:10 UTC
(In reply to Roman Kuznetsov from comment #4)
> Default Header styles are built-in styles in LibreOffice, and Outline for it
> just is hardcoded.

The issue is that when you _modify_ a style the entries under Outline & Numbering are disabled without an unclear reason. It happens for example for "Heading 1" but not "Text Body". Reason is that the paragraph style is linked to a list style. You have to go to Tools > Chapter Numbering and set Paragraph Style for Heading 1 to None in order to be able to change the properties Outline/Numbering in the styles dialog. 
Our poor solution is to make this relation more clear in the dialog.

(Also an interesting aspect for documentation, CC'ing Olivier)
Comment 8 Buovjaga 2019-01-17 17:25:51 UTC
I guess these are relevant: bug 83071 & bug 83369
Comment 9 Heiko Tietze 2019-01-18 09:23:05 UTC
I added a tooltip "This option is disabled when chapter numbering is assigned to a paragraph style" that is only shown when the controls are disabled.

Patch is here https://gerrit.libreoffice.org/#/c/66575/
Comment 10 Commit Notification 2019-01-18 11:24:06 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0945136575835844ec70abc00a7487ed6b3ff481%5E%21

Resolves tdf#122637 - Disabled controls in Outline & Numbering unclear

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Cor Nouws 2019-01-18 17:13:46 UTC
(In reply to Commit Notification from comment #10)
> https://git.libreoffice.org/core/+/
> 0945136575835844ec70abc00a7487ed6b3ff481%5E%21
Very nice solution!