Bug 122651 - LibreOffice hangs after canceling the help not-installed dialog (gtk/gen)
Summary: LibreOffice hangs after canceling the help not-installed dialog (gtk/gen)
Status: RESOLVED DUPLICATE of bug 122404
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-01-11 11:49 UTC by Xisco Faulí
Modified: 2019-01-11 12:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-01-11 11:49:15 UTC
Steps to reproduce:
1. Open Impress -> 'Select a Template' dialog is displayed
2. Click on Help
3. if help is not installed, the help is not installed dialog will be diplayed.
4. Click on Cancel
-> it's not possible to interact with LibreOffice anymore

Same happens from the Extension dialog

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: c164dbaff63d67f5e89d133c272412aaf4c5c158
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-01-11 11:50:42 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=096b455583aa23d554cd05b1fac8909b7e10e355

author	Caolán McNamara <caolanm@redhat.com>	2018-12-23 17:46:48 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-01-09 11:50:16 +0100
commit	096b455583aa23d554cd05b1fac8909b7e10e355 (patch)
tree	9c96d1be665e765c59ff9dc246bd210435a43672
parent	47faab780f2a099715a95ce6f3c5228f0fe0c599 (diff)
tdf#122273 modal dialog on modeless dialog needs special handling

Bisected with: bibisect-linux64-6.3

Adding Cc: to Caolán McNamara
Comment 2 Caolán McNamara 2019-01-11 12:16:27 UTC
Is this a duplicate of bug 122404 or an additional problem ?
Comment 3 Xisco Faulí 2019-01-11 12:58:12 UTC
(In reply to Caolán McNamara from comment #2)
> Is this a duplicate of bug 122404 or an additional problem ?

Indeed, it's a duplicated.
Verified in


Version: 6.3.0.0.alpha0+
Build ID: a0210c5c5e8fd47b55567a8b18788d57d2b7decb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

*** This bug has been marked as a duplicate of bug 122404 ***