Bug 122657 - Converting .odt file to PDF contains fonts that are not in the .odf file
Summary: Converting .odt file to PDF contains fonts that are not in the .odf file
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2019-01-11 16:25 UTC by cmflatscher
Modified: 2021-07-31 15:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Frist Writer file (328.93 KB, application/vnd.oasis.opendocument.text)
2019-01-12 23:59 UTC, cmflatscher
Details
Second Writer file (327.71 KB, application/vnd.oasis.opendocument.text)
2019-01-13 00:00 UTC, cmflatscher
Details
First PDF file created (953.91 KB, application/pdf)
2019-01-13 00:00 UTC, cmflatscher
Details
Second PDF file (958.72 KB, application/pdf)
2019-01-13 00:00 UTC, cmflatscher
Details
Sample files with font information (24.56 KB, application/x-zip-compressed)
2021-07-31 14:59 UTC, cmflatscher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cmflatscher 2019-01-11 16:25:17 UTC
Hi,

I have a LO Writer Document that contains a number of open source fonts including Google Noto fonts.

When I convert this .odt file to a PDF file then the resulting PDF file contains fonts that are not in the original .odt file.

It was observed in this set up:

Windows 10 Pro, Version 1803, Build 17134.523
LibreOffice 6.1.1.2
LibreOffice 6.2.0.2

Windows XP SP2 32-bit
LibreOffice 4.4.5.2

In Windows 10 the following fonts are automatically embedded:
Tahoma and Lucida Sans

I have unpacked the .odt file and searched the entire content for both fonts to no avail.

Please let me know what is required to solve this problem.

Please help solve this issue.

Thank you!

--Christian
Comment 1 Dieter 2019-01-11 17:37:51 UTC Comment hidden (obsolete)
Comment 2 cmflatscher 2019-01-12 23:59:19 UTC
Created attachment 148278 [details]
Frist Writer file

See comments for more information.
Comment 3 cmflatscher 2019-01-13 00:00:07 UTC
Created attachment 148279 [details]
Second Writer file

See comments for more information.
Comment 4 cmflatscher 2019-01-13 00:00:35 UTC
Created attachment 148280 [details]
First PDF file created

See comments for more information.
Comment 5 cmflatscher 2019-01-13 00:00:59 UTC
Created attachment 148281 [details]
Second PDF file

See comments for more information.
Comment 6 cmflatscher 2019-01-13 00:05:54 UTC
Hi Dieter,

Thank you for picking up this bug.

The files that I have created do not contain anything confidential that requires removing.

I have attached two LibreOffice writer files and the PDF files that I created with LibreOffice writer.

Here are the fonts that I used in the files:

Fira
NotoNaskhArabic-hinted.zip
NotoSansCJKjp-hinted.zip
NotoSansCJKkr-hinted.zip
NotoSansCJKsc-hinted.zip
NotoSansCJKtc-hinted.zip
NotoSansHebrew-hinted.zip
NotoSerif-hinted.zip

At a later stage some more Noto fonts will be added.

I created the PDF files a few minutes ago. What is rather intriguing is the fact that this time round not the Lucida Sans font but ArialUnicodeMS font is included. The Tahoma font is still there.

Please have a look and advise how this can be resolved from my side or if this is a bug from LO Writer.

Thank you.

--Christian
Comment 7 cmflatscher 2019-01-13 00:05:54 UTC Comment hidden (obsolete)
Comment 8 cmflatscher 2019-01-13 00:06:21 UTC Comment hidden (obsolete)
Comment 9 Dieter 2019-01-17 19:45:34 UTC
I exported the First Writer file and got the following unexpected fonts embedded in the PDF:
Arial
Liberation
LucidaSans
Tahoma

So I change status to NEW, but I think, we can treat it as a duplicate of bug 118541. If you agree, please change status to RESOLVED DUPLICATE.
Comment 10 cmflatscher 2019-01-18 11:16:31 UTC Comment hidden (obsolete)
Comment 11 Dieter 2019-01-18 11:30:46 UTC Comment hidden (obsolete)
Comment 12 cmflatscher 2019-01-18 16:49:31 UTC Comment hidden (obsolete)
Comment 13 Timur 2021-04-15 13:59:21 UTC
IIUC, no forms in this sample, so no duplicate of form bug. 
I see that Tshoma is in PDF in Windows, not in Linux export. 
But that is not enough to confirm the bug. 
I guess it is a replacement font for some missing or some style font. 
It would be easier if you attached minimal sample, but full document.
Comment 14 Dmitriy Siushkin 2021-07-26 13:45:22 UTC
am i right,that there must be only Noto fonts in created PDF file and nor others?

repro in 
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c5ca46e75e28ba4245d8544ca53c71fea87d1bbd
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (ru_RU); UI: en-US
Calc: CL



and result:

arial-black
arialNarrow-BoldItalic
LiberationMono
LiberationSans
LiberationSans-Italic
LucidaSans
MS-UIGothic
NotoNaskhArabic
NotoSansHebrew
NotoSerif
OpenSymbol
SimSun
Tahoma
Comment 15 cmflatscher 2021-07-27 09:42:52 UTC
Hi Dmitry,

It is not specific to the use of Noto fonts.

I have a ~ 91 MB .odt file that I created for work. I can provide it to you under the following conditions:

1. The document is not to be shared outside LO support
2. The upload location must be secure in that nobody can download it from anywhere I need to upload it, except for LO support

If the two above requirements can be met, then please provide me with an upload location for this document.

Once you convert it to PDF you can reproduce this issue both in Windows and Linux.

Thank you.

Regards,

--Christian
Comment 16 QA Administrators 2021-07-28 04:06:53 UTC Comment hidden (obsolete)
Comment 17 cmflatscher 2021-07-31 14:58:16 UTC
Just as FYI - I consider this problem report not a duplication of bug bug 118541.
Comment 18 cmflatscher 2021-07-31 14:59:46 UTC
Created attachment 173999 [details]
Sample files with font information
Comment 19 cmflatscher 2021-07-31 15:05:20 UTC
I have attached the file fonts.zip containing these text files:

fonts_linux.txt - fonts embedded into the PDF file when created in Kubuntu

fonts_windows.txt - fonts embedded into the PDF file when created in Windows

installed_fonts_windows.txt - All fonts installed in Windows

odt_fonts.txt - fonts actually in the .odt file as created by the "Test of missing fonts" add on v1.4.5, available via https://extensions.openoffice.org/en/project/testfonts