Download it now!
Bug 122660 - Images not displayed in .pub document
Summary: Images not displayed in .pub document
Status: RESOLVED DUPLICATE of bug 130479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 129090 130289 (view as bug list)
Depends on:
Blocks: Regressions-imageHandling
  Show dependency treegraph
 
Reported: 2019-01-11 18:43 UTC by Buovjaga
Modified: 2020-05-21 23:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
FlatODF reproducer (3.41 MB, application/vnd.oasis.opendocument.graphics-flat-xml)
2019-02-11 11:39 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2019-01-11 18:43:03 UTC
1. Open attachment 99486 [details] from bug 69080

There should be images on pages 2, 3 and 4.

Bibisected with win32-6.1 to https://gerrit.libreoffice.org/plugins/gitiles/core/+/a3488acbeb3b618cf5b6b1a93608c58d0eb9d646%5E!/

upload libmspub 0.1.3

Adding Cc: to David Tardon

Also seen with
Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: c2d59ec2832c8b51568e73e9314ab9c82f1f5b7b
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 8 January 2019
Comment 1 David Tardon 2019-02-09 13:26:10 UTC
The upload of libmspub 0.1.3 is red herring. The bug observed there is bug 116018, that was only fixed by upload of libmspub 0.1.4 on the 6.1 branch. In contrast, there are no missing images in libreoffice 6.0.x, which contains libmspub 0.1.3 too, just with a separate patch for bug 116018. I also see no problem with libreoffice 6.0/libmspub 0.1.4 combination on Fedora 28. On Fedora 29, however, which ships libreoffice 6.1, the bug is reproducible with _any_ version of libmspub down to 1.0.

In summary: the regression is in libreoffice and was introduced in the period between upload of libmspub 0.1.3 and 0.1.4 (a3488acbeb3b618cf5b6b1a93608c58d0eb9d646..38368a9ec30d1979f03f4b7035a1c5ecb9ac24e6).

Unfortunately, bundled libmspub is built statically, so it's not possible to use a fixed version with the bibisect repo. It'll have to be bisected, which will take some time :-)
Comment 3 David Tardon 2019-02-11 11:39:41 UTC
Created attachment 149115 [details]
FlatODF reproducer

I'm attaching a FlatODF document converted from the original .pub by pub2odg (that's the same thing that libreoffice gets as output from the Publisher input filter). The bug can be reproduced with it as well.
Comment 4 Xisco Faulí 2019-11-29 10:45:33 UTC
*** Bug 129090 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2019-11-29 10:46:24 UTC
Miklos, I thought you might be interested in this issue...
Comment 6 Andrea Giudiceandrea 2019-11-29 11:03:42 UTC
Images in MS Publisher .pub files images are still not displayed with
LibreOffice Draw
Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed

on Windows 7 Home Premium SP1 64 bit.

The bug was not present with LibreOffice 5.4.3.2.

See also https://bugs.documentfoundation.org/show_bug.cgi?id=129090#c3
Comment 7 Andrea Giudiceandrea 2019-11-29 12:25:45 UTC
The bug was not present also in Version: 6.0.7.3 (x64) Build ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5 on Windows 7 SP1 64 bit
Comment 8 Timur 2020-01-30 18:00:14 UTC
*** Bug 130289 has been marked as a duplicate of this bug. ***
Comment 9 paulystefan 2020-04-08 23:01:03 UTC
repro in 6.4.2.2
Comment 10 Aron Budea 2020-05-21 05:36:16 UTC
This got fixed between yesterday and today's daily build, must be because of bug 130479's fix. Marking as duplicate.

I'm seeing that the image on page 2 is blurrier than in 6.0, Buovjaga, please open a follow-up bug report on that.

*** This bug has been marked as a duplicate of bug 130479 ***