Bug 122662 - Menubar in opened forms is greyed out with VCL: gtk3
Summary: Menubar in opened forms is greyed out with VCL: gtk3
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.1.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2019-01-11 18:52 UTC by Robert Großkopf
Modified: 2019-01-29 10:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot shows disabled menubar (and also no borders arround form controls) (67.10 KB, image/png)
2019-01-12 07:13 UTC, Robert Großkopf
Details
I can't reproduce it in LibreOffice 6.3 master gtk3 (66.12 KB, image/png)
2019-01-17 11:24 UTC, Xisco Faulí
Details
One Exmaple - just open the form with LO and gtk3 (43.94 KB, application/vnd.oasis.opendocument.database)
2019-01-17 12:37 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2019-01-11 18:52:57 UTC
Open any database.
Open any form for input data.
The menubar of the form is completely disabled.

This bug happens with
Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: en-US (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

Doesn't appear with LO 6.1.4.2 on OpenSUSE 15 64bit rpm Linux
Comment 1 Robert Großkopf 2019-01-12 07:13:21 UTC
Created attachment 148257 [details]
Screenshot shows disabled menubar (and also no borders arround form controls)
Comment 2 Alex Thurgood 2019-01-14 11:42:47 UTC
I can't confirm this on macOS, I still see the active menus when opening a form.

Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Mac OS X 10.14.2; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

However, I did have discussion on QA recently (last week) about the main menu being missing with GTK3 backend on Ubuntu and Mate desktops and my Linux master build there.

@Robert : if you start LO with the GEN vcl plugin instead of the default for your desktop manager, does the main menu re-appear ?
Comment 3 Alex Thurgood 2019-01-14 11:44:12 UTC
The missing borders on controls in Forms has also been raised (by Drew) on another issue ?
Comment 4 Robert Großkopf 2019-01-14 15:12:45 UTC
(In reply to Alex Thurgood from comment #3)
> The missing borders on controls in Forms has also been raised (by Drew) on
> another issue ?

This is what I reported as bug 122661
Comment 5 Robert Großkopf 2019-01-14 15:18:15 UTC
(In reply to Alex Thurgood from comment #2)
> 
> @Robert : if you start LO with the GEN vcl plugin instead of the default for
> your desktop manager, does the main menu re-appear ?

How could I execute this? Have had a look at start-parameters didn't find any parameter for VCL.
Comment 6 Alex Thurgood 2019-01-14 15:39:32 UTC
Hi Robert,

You could try using SAL_USE_VCLPLUGIN=gen from a terminal before launching the soffice script from that terminal, or I believe you can still alter the soffice script itself to insert that in there.
Comment 7 Robert Großkopf 2019-01-14 20:25:07 UTC
(In reply to Alex Thurgood from comment #6)
> Hi Robert,
> 
> You could try using SAL_USE_VCLPLUGIN=gen from a terminal before launching
> the soffice script from that terminal, or I believe you can still alter the
> soffice script itself to insert that in there.

You are right. It doesen't appear with VCL: x11; - but its a horrible GUI with very small fonts ...

So a special bug for gtk3?
Comment 8 Alex Thurgood 2019-01-17 08:13:02 UTC
Confirmed per comment 2
Comment 9 Xisco Faulí 2019-01-17 11:24:50 UTC
Created attachment 148393 [details]
I can't reproduce it in LibreOffice 6.3 master gtk3
Comment 10 Xisco Faulí 2019-01-17 11:25:09 UTC
@Robert Großkopf, could you please attach the database you're using ?
Comment 11 Robert Großkopf 2019-01-17 12:37:41 UTC
Created attachment 148397 [details]
One Exmaple - just open the form with LO and gtk3

Its the same behaviour in every database. I have added one. Open the form for input data shows disabled menues here:

Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: en-US (de_DE.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Xisco Faulí 2019-01-17 12:41:57 UTC
True, this is a about the menubar. didn't see it the first time...

Version: 6.3.0.0.alpha0+
Build ID: 5e89aad61e143ad6a52291ef7065f5b22e348c85
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 13 Xisco Faulí 2019-01-17 12:43:46 UTC
BTW, it's not disabled, just greyed out
Comment 14 Xisco Faulí 2019-01-17 12:48:58 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1115a60e6d825c049680e7f2caf318e36d481b12

author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2018-06-19 11:47:08 +0200
committer	Stephan Bergmann <sbergman@redhat.com>	2018-06-19 14:13:33 +0200
commit	1115a60e6d825c049680e7f2caf318e36d481b12 (patch)
tree	8e7922b4eb40961c61cb6822b50c3ce427b53098
parent	3b6905e37a6baac08eaff00e6e42aced7d6896df (diff)
tdf#118238 Only disable UI interaction when loading document as hidden

Bisected with: bibisect-linux64-6.2

Adding Cc: to Samuel Mehrbrodt
Comment 15 Xisco Faulí 2019-01-17 12:49:52 UTC
@Caolán, I thought you might be interested in this issue...
Comment 16 Caolán McNamara 2019-01-17 13:07:31 UTC
I'm not seeing it in my gtk3 version, is it just painted in a grayed out mode, or is it actually disabled ?
Comment 17 Robert Großkopf 2019-01-17 14:36:01 UTC
(In reply to Caolán McNamara from comment #16)
> I'm not seeing it in my gtk3 version, is it just painted in a grayed out
> mode, or is it actually disabled ?

You are right. When I open it in KDE it is only grayed out. I could choose content of the menues. Must switch to XFCE, where I have seen it first.
Comment 18 Robert Großkopf 2019-01-17 14:44:18 UTC
(In reply to Robert Großkopf from comment #17)
> (In reply to Caolán McNamara from comment #16)
> > I'm not seeing it in my gtk3 version, is it just painted in a grayed out
> > mode, or is it actually disabled ?
> 
> You are right. When I open it in KDE it is only grayed out. I could choose
> content of the menues. Must switch to XFCE, where I have seen it first.

It's the same behaviour in XFCE. Doesn't know what I have seen when reporting the bug. So the only bug is the menue is greyed out.
Comment 19 Robert Großkopf 2019-01-22 17:02:35 UTC
Have just had the same behaviour, not reproducable every time, when opening a Writer-document with LO 6.1.3.2 from OpenSUSE-repositories SUSE 15, 64bit rpm Linux. This version also uses gtk3 and the menue was greyed out.
Comment 20 Caolán McNamara 2019-01-23 15:17:25 UTC
Is it theme related, if you use gnome-tweak-tool/gnome-tweaks and select e.g. Adwaita does that one have the same effect ?
Comment 21 Robert Großkopf 2019-01-23 15:30:55 UTC
(In reply to Caolán McNamara from comment #20)
> Is it theme related, if you use gnome-tweak-tool/gnome-tweaks and select
> e.g. Adwaita does that one have the same effect ?

You are right. I changed (in XFCE) from Clearlooks-Phenix to Adwaita and the menubar isn't greyed out. Also changing to Breeze shows the menubar the right way. Maybe there is something wrong with Clearlooks-Phenix I use for screenshots. I will get the following gtk-warnings from soffice:
---------------
(soffice:4521): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: not a number
(soffice:4521): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1594:13: Expected a string.
(soffice:4521): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1976:11: not a number
(soffice:4521): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1976:11: Expected a string.
(soffice:4521): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2526:11: not a number
(soffice:4521): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2526:11: Expected a string.
(soffice:4521): Gtk-WARNING **: Theme parsing error: applications.css:21:0: Expected a valid selector
---------------
I'm using this theme only for the screenshots for the Base-Handbook, but there seems to be something wrong - only together with LO ...
Comment 22 Caolán McNamara 2019-01-23 16:16:33 UTC
I installed Clearlooks-Phenix and now I can reproduce it
Comment 23 Caolán McNamara 2019-01-24 08:59:14 UTC
I think the state of the context used by gtk itself has gotten stuck as disabled from getting reused by libreoffice in the foreign drawing usage
Comment 24 Commit Notification 2019-01-24 09:20:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/114ed1814c8cee31f90585578755c9fe20a0618a%5E%21

Related: tdf#122662 unused condition

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2019-01-24 12:42:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/626ae6a6e64d9ea7b5bbf2f22ff7798b54b61384%5E%21

Resolves: tdf#122662 restore context after changing state

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Caolán McNamara 2019-01-24 12:52:43 UTC
fixed in master, backports in gerrit
Comment 27 Commit Notification 2019-01-25 08:32:09 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/c7d36095c8e7205d9b9ef3e43728c36f027b457c%5E%21

Resolves: tdf#122662 restore context after changing state

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Xisco Faulí 2019-01-28 16:13:05 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 58f30cf1fe401452c0297703fe08a9aa14bd55f3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, Thanks for fixing this!
Comment 29 Commit Notification 2019-01-29 10:03:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/36d5fd037439f84a688b96ec5af9e47d4a58712e%5E%21

Resolves: tdf#122662 restore context after changing state

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.