Download it now!
Bug 122666 - UI: Duplicate and ambiguous function names in Customise \ Keyboard
Summary: UI: Duplicate and ambiguous function names in Customise \ Keyboard
Status: RESOLVED DUPLICATE of bug 108458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-12 02:12 UTC by Sam
Modified: 2019-06-12 12:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Increase indent toolbar button (2.40 KB, image/png)
2019-01-12 02:13 UTC, Sam
Details
'Customise' dialog window (21.67 KB, image/png)
2019-01-12 02:14 UTC, Sam
Details
printscreen (75.44 KB, image/png)
2019-01-12 07:54 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sam 2019-01-12 02:12:53 UTC
Description:
The 'Customise' pop-up dialog, under 'Keyboard' tab displays a list of functions in the middle list-view.

Some function names in the list-view are displayed multiple times. Examples:
* 'Increase' listed 3 times
* 'Insert cells' listed 2 times
* 'Left' listed 3 times
* 'Line' listed 2 times

Searching also does not work properly. For example, it is not possible to find the 'Increase indent' function by searching for 'indent'.

Steps to Reproduce:
1. Open LibreOffice Calc.
2. Select Tools menu. Select Customise.
3. Activate Keyboard tab.
4. Scroll within the function name list-view, or search for a specific function (eg 'increase indent').

Actual Results:
a. When searching for 'increase indent', there are no results.
b. When searching for 'indent', there are no results.
c. When searching for 'increase', there are 3 results, and it is not possible to tell which (if any) is actually 'Increase indent'.

Expected Results:
a. Function 'Increase indent' listed.
b. Function 'Increase indent' listed.
c. Function 'Increase indent' listed.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-AU (en_AU); Calc: CL
Comment 1 Sam 2019-01-12 02:13:51 UTC
Created attachment 148251 [details]
Increase indent toolbar button
Comment 2 Sam 2019-01-12 02:14:33 UTC
Created attachment 148252 [details]
'Customise' dialog window
Comment 3 raal 2019-01-12 07:54:36 UTC
Created attachment 148258 [details]
printscreen

Tested with Version: 6.3.0.0.alpha0+
Build ID: 892a5cfe557edb405ec0037676f02a1c24dd76ec
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

Increase command is not written correctly, see printscreen. tested searching and it works correctly, for instance try to search "row"
Comment 4 Xisco Faulí 2019-01-15 17:35:48 UTC
Thanks for reporting this issue.
Seem the same as bug 122523. Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 122523 ***
Comment 5 V Stuart Foote 2019-06-12 12:35:27 UTC
QA - adjusting duplicate

*** This bug has been marked as a duplicate of bug 108458 ***