Bug Hunting Session
Bug 122685 - Waste text
Summary: Waste text
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-13 07:57 UTC by 00
Modified: 2019-03-15 15:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
1 (284.68 KB, image/png)
2019-01-13 08:05 UTC, 00
Details
I thought of it, in the "custom", add the "expansion kit" option, you can complete the "expansion kit" toolbar. (209.70 KB, image/png)
2019-02-06 06:55 UTC, 00
Details
1. In "Customize", add the option of "Expansion Kit". (50.92 KB, image/png)
2019-03-14 08:04 UTC, 00
Details
『Extension Manager』 toolbar (368.74 KB, image/png)
2019-03-15 07:20 UTC, 00
Details
In "Customize", add the option of " Extension Manager ". (53.27 KB, image/png)
2019-03-15 07:21 UTC, 00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 00 2019-01-13 07:57:21 UTC
Description:
The "Expansion Kit" toolbar is the same as the toolbar of the browser.

The "Expansion Kit" toolbar, because it can be pressed with the mouse, will add a lot of features.

Since "Firefox" is a free software, it is good to copy the design of "Firefox" directly.

Writer, Calc, Impress, Draw, Math, Base, all use this design.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 00 2019-01-13 08:05:04 UTC Comment hidden (obsolete)
Comment 2 Regina Henschel 2019-01-13 21:15:32 UTC
I do not understand you. What is the purpose of the "Expansion Kit" toolbar?
Comment 3 00 2019-01-14 07:27:44 UTC
(In reply to Regina Henschel from comment #2)
> I do not understand you. What is the purpose of the "Expansion Kit" toolbar?


Like the toolbar of the browser,
Because you can use the "snap button",
So it will add a lot of features,
E.g,
Drop down menu
carried out
End
...and many more

Can you use the "snap button", a lot worse.

Focus
I think the "Expansion Kit" toolbar will definitely attract more people to write programs.
Because the browser has the "Expansion Kit" toolbar, it attracts more people to write programs, and Google uses this trick to defeat Microsoft.
The "Expansion Kit" toolbar is also considered a "strategy."
Comment 4 00 2019-02-06 06:55:31 UTC Comment hidden (obsolete)
Comment 5 himajin100000 2019-02-06 08:45:27 UTC
Looking around many Extensions on https://extensions.libreoffice.org/extensions , 
I now want to develop my own extension "himajin100000's brilliant Hello World Extension". It just shows a greeting on a messagebox. I want to make the extension easy to use for a very little child. Toolbar button would be ideal. He would just need to click a button with my original png image on the toolbar, but can I do that? Does LibreOffice supports such feature?
Comment 6 himajin100000 2019-02-06 09:05:16 UTC
I would be even happier if I could create a toolbar exclusive to my extension.
Comment 7 Xisco Faulí 2019-03-13 19:00:46 UTC
Hi 和尚蟹, himajin100000,
could you please clarify what this enhancement is about? It is really difficult to understand what its purpose. Thanks
Comment 8 00 2019-03-14 06:51:09 UTC
(In reply to Xisco Faulí from comment #7)

Forcing the "expansion kit", you must have the "pattern" of the toolbar.
Comment 9 00 2019-03-14 07:41:40 UTC
(In reply to Xisco Faulí from comment #7)

1. In "Customize", add the option of "Expansion Kit".
2, mandatory "expansion kit", there must be a "pattern" of the tool bar.
   ◎, because "pattern" is the "button".
Comment 10 Xisco Faulí 2019-03-14 07:46:43 UTC
and what is a expansion kit ?
Comment 11 00 2019-03-14 08:04:32 UTC Comment hidden (obsolete)
Comment 12 00 2019-03-14 14:59:41 UTC
Expansion Kit→Extension manager
Comment 13 00 2019-03-15 07:20:13 UTC
Created attachment 149983 [details]
『Extension Manager』 toolbar
Comment 14 00 2019-03-15 07:21:37 UTC
Created attachment 149984 [details]
In "Customize", add the option of " Extension Manager ".
Comment 15 Xisco Faulí 2019-03-15 08:51:48 UTC
This bug was poorly described since the moment it was reported and now we have 14 messages trying to figure out what it's about.
I'm going to close this one as RESOLVED INVALID. Please, report a new bug with the proper naming and a clear description. Thanks