Bug 122689 - Cannot copy text from/to Libreoffice to/from other application in KDE
Summary: Cannot copy text from/to Libreoffice to/from other application in KDE
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.2.2
Keywords:
: 123596 123776 123946 124033 124229 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-01-13 12:11 UTC by Ioannis Ilousis-Iliadis
Modified: 2019-03-25 17:47 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ioannis Ilousis-Iliadis 2019-01-13 12:11:43 UTC
Description:
Issue does not exist in Windows version.
Issue probably arose after fixing bug https://bugs.documentfoundation.org/show_bug.cgi?id=122252

Steps to Reproduce:
Copy any text from/to Libreoffice to/from other application in KDE

Actual Results:
Copy of text is expected to take place

Expected Results:
No text is copied


Reproducible: Always


User Profile Reset: Yes



Additional Info:
LibreOffice Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: el-GR (el_GR.UTF-8); UI-Language: en-US
Calc: threaded

KDE Plasma Version 5.13.5
Comment 1 Michael Weghorn 2019-01-15 13:49:40 UTC
I can reproduce with

Version: 6.3.0.0.alpha0+
Build ID: de63114d76433b5a1f1ed0286e28545c72330630
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

even though it's not always reproducible in my case, rather seems to be somewhat "flaky"...
Comment 2 Michael Weghorn 2019-01-15 13:56:16 UTC
In a quick test in my case, using Kate and LibreOffice Writer, it seems that copying from Kate to Writer works OK up to the point I select and copy some text in Writer. From that point on, copying and pasting between the applications no longer works.

@Ioannis: Can you possibly confirm this behaviour?
Comment 3 Ioannis Ilousis-Iliadis 2019-01-15 14:07:42 UTC
(In reply to Michael Weghorn from comment #2)

> [...] copying from Kate to Writer works [...]
> @Ioannis: Can you possibly confirm this behaviour?

Yes, I can also copy from Kate to Writer (but not the opposite).
Comment 4 Commit Notification 2019-01-21 12:17:23 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3d4fe8b13545ee4d2992d33638f90855080d09d3%5E%21

tdf#122689 KDE5: Fix selection clipboard

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Vera Blagoveschenskaya 2019-01-23 11:31:37 UTC
Version: 6.3.0.0.alpha0+
Build ID: 6e80862ee6851b75fc7fa628156400bb044391ee
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-22_16:54:24
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Select and push middle button:
Copy/paste works fine from KWrite to LO Writer/Calc and vise versa

Copy and Paste via context menu OR Ctlr+C/Ctrl+V:
Copy/paste from LO Writer/Calc to KWrite works fine
I still cannot copy from KWrite to LO Writer/Calc

See also https://bugs.documentfoundation.org/show_bug.cgi?id=122239
Comment 6 Vera Blagoveschenskaya 2019-01-23 14:48:05 UTC
(In reply to Vera Blagoveschenskaya from comment #5)
> Version: 6.3.0.0.alpha0+
> Build ID: 6e80862ee6851b75fc7fa628156400bb044391ee
> CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2019-01-22_16:54:24
> Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> Select and push middle button:
> Copy/paste works fine from KWrite to LO Writer/Calc and vise versa
> 
> Copy and Paste via context menu OR Ctlr+C/Ctrl+V:
> Copy/paste from LO Writer/Calc to KWrite works fine
> I still cannot copy from KWrite to LO Writer/Calc
> 
> See also https://bugs.documentfoundation.org/show_bug.cgi?id=122239

I've investigated this issue more precisely (the behavior differs for Writer and Calc!):

1. Text Selection and middle button
1.1.1. LO Writer --> KWrite = BUG (doesn't work)
1.1.2. KWrite --> LO Writer = OK (works fine)

1.2.1. LO Calc --> KWrite = OK
1.2.2. KWrite --> LO Calc = OK

2. Copy and Paste via context menu
2.1.1. LO Writer --> KWrite = OK
2.1.2. KWrite --> LO Writer = BUG

2.2.1. LO Calc --> KWrite = OK
2.2.2. KWrite --> LO Calc = BUG
Comment 7 Ioannis Ilousis-Iliadis 2019-01-25 18:37:42 UTC
(In reply to Commit Notification from comment #4)
> Affected users are encouraged to test the fix and report feedback.


Version: 6.3.0.0.alpha0+
Build ID: 6e80862ee6851b75fc7fa628156400bb044391ee
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-22_16:54:24
Locale: el-GR (el_GR.UTF-8); UI-Language: en-US
Calc: threaded


Only, after deleting settings folder, after a fresh start (restart if already open) of Calc/Writer, the behavior is:

->         LO Calc             LO Writer
Kate       copy, middle_click  copy, middle_click

->         Kate
LO Calc    copy, middle_click
LO Writer  copy
Comment 8 Commit Notification 2019-02-04 16:23:03 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/6e2b2d7f394f5e7e7052cc5b27adf0a7a60901ff%5E%21

tdf#122689 KDE5: Fix selection clipboard

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Michael Weghorn 2019-02-23 11:39:00 UTC
(In reply to Vera Blagoveschenskaya from comment #6)
> I've investigated this issue more precisely (the behavior differs for Writer
> and Calc!):
> 
> 1. Text Selection and middle button
> 1.1.1. LO Writer --> KWrite = BUG (doesn't work)
> 1.1.2. KWrite --> LO Writer = OK (works fine)
> 
> 1.2.1. LO Calc --> KWrite = OK
> 1.2.2. KWrite --> LO Calc = OK
> 
> 2. Copy and Paste via context menu
> 2.1.1. LO Writer --> KWrite = OK
> 2.1.2. KWrite --> LO Writer = BUG
> 
> 2.2.1. LO Calc --> KWrite = OK
> 2.2.2. KWrite --> LO Calc = BUG

A fix for 2. is pending at https://gerrit.libreoffice.org/#/c/68214/ .

For 1. (primary selection/middle mouse paste), there's also bug 122239, so I suggest to close this one here once 2. has been fixed and keep track of the remaining things in that bug report.
Comment 10 Commit Notification 2019-02-27 19:57:54 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/9c5dbbe4b0a62ff1af009beb00f1fc45318dad79%5E%21

tdf#122689 qt5: Consider external clipboard updates

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-02-28 11:58:10 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1cc66501179f2a396e221d6803f2e1f8019ada5c%5E%21

tdf#122689 qt5: Consider external clipboard updates

It will be available in 6.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Vera Blagoveschenskaya 2019-03-01 13:14:33 UTC
Thanks, Michael!

I've checked the fix 2 for the build:

Version: 6.3.0.0.alpha0+
Build ID: f23738139429358c11fa62708fbdf5bb0c43d199
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-28_20:14:57
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded


(In reply to Vera Blagoveschenskaya from comment #6)
> I've investigated this issue more precisely (the behavior differs for Writer
> and Calc!):
> 
> 1. Text Selection and middle button
> 1.1.1. LO Writer --> KWrite = BUG (doesn't work)
> 1.1.2. KWrite --> LO Writer = OK (works fine)
> 
> 1.2.1. LO Calc --> KWrite = OK
> 1.2.2. KWrite --> LO Calc = OK
> 

NOT fixed, will be fix in bug 122239

> 2. Copy and Paste via context menu
> 2.1.1. LO Writer --> KWrite = OK
> 2.1.2. KWrite --> LO Writer = BUG
> 
> 2.2.1. LO Calc --> KWrite = OK
> 2.2.2. KWrite --> LO Calc = BUG

FIXED! Copy and paste works fine in all cases.
Comment 13 Dieter Praas 2019-03-02 11:55:34 UTC
*** Bug 123776 has been marked as a duplicate of this bug. ***
Comment 14 Buovjaga 2019-03-14 08:33:19 UTC
*** Bug 123596 has been marked as a duplicate of this bug. ***
Comment 15 Michael Weghorn 2019-03-16 17:20:27 UTC
*** Bug 124033 has been marked as a duplicate of this bug. ***
Comment 16 Michael Weghorn 2019-03-18 14:12:30 UTC
*** Bug 123776 has been marked as a duplicate of this bug. ***
Comment 17 Xisco Faulí 2019-03-20 23:07:00 UTC
*** Bug 124229 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2019-03-25 17:47:04 UTC
*** Bug 123946 has been marked as a duplicate of this bug. ***