Bug 122751 - Tabbed: Missing Some Required Functions from Previous Pop Up Toolbar in Tabbed interface
Summary: Tabbed: Missing Some Required Functions from Previous Pop Up Toolbar in Tabbe...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2019-01-16 04:58 UTC by Rizal Muttaqin
Modified: 2019-04-07 07:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Draw tab contextual toolbar instead of fontwork toolbar commands (330.36 KB, image/png)
2019-01-16 09:53 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2019-01-16 04:58:04 UTC
As some toolbars now hidden by default when activating Notebookbar interface (https://bugs.documentfoundation.org/show_bug.cgi?id=103226), some functions is not available in Tabbed. It is showed in Standard toolbar by default while the button or function has not provided yet by Tabbed interface:

So far I've found two toolbars which the specific functions need to be provided by a new dedicated Tab __OR__ for workaround set the pop up enable (just like Chart):

1. Bullets and Numbering
2. Fontwork

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 411f3a050ac2be598019d512f8ccfe041080c28f
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-14_03:17:11
Locale: id-ID (id_ID); UI-Language: en-US
Calc: threaded
Comment 1 andreas_k 2019-01-16 07:42:44 UTC
can you be more specific with bullets and numbering and fontwork.
Comment 2 andreas_k 2019-01-16 07:45:12 UTC
Bullets and Numbering should be in home tab and 
Fontwork in in the insert tab but in the insert drop down menu (on the right)
Comment 3 Dieter Praas 2019-01-16 08:15:17 UTC
Rizal, I have set the bug's status to 'NEEDINFO' because of comment 1 and comment 2. Please change it back to 'UNCONFIRMED' once the requested informations are given. Perhaps you could also add a screenshot to make it more clear.
Comment 4 Pedro 2019-01-16 09:53:14 UTC
Created attachment 148355 [details]
Draw tab contextual toolbar instead of fontwork toolbar commands

Ok, so to replicate these issues.

Default behavious in Standard Toolbar UI 
1 - Insert Fontwork,
2 - In standard toolbar view, when Fontwork is selected there is the Fontwork toolbar with the following commands - Fontwork Shape, Fontwork Same Letter Heights, Fontwork Alignment, Fontwork Character Spacing and Toggle Extrusion.

In Notebookbar UIs (Groupedbar and Tabbed UIs)
1 - Insert Fontwork,
2 - When Fontwwork is selected instead of showing the uno commands present in Fontwork toolbar, related with Fontwork editing the contextual tab / group that appears are the Draw tab.

Proposed fix:
Create a contextual Fontwork tab with the uno commands present in Fontwork toolbar.
Comment 5 Heiko Tietze 2019-03-25 08:44:03 UTC
No input from UX needed as the NB variants are designed for particular situations and the decision is up to the author. 

Andreas, please set the status to NEW if you accept the request or RESOLVED+WFM/WF/NAB... otherwise.
Comment 6 andreas_k 2019-04-06 22:52:07 UTC
thanks for reporting this bug. I add fontwork to draw tab/context menu and the bullet stuff to writer home dropdown menu.
Comment 7 Commit Notification 2019-04-07 07:19:18 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e967aea2d8cc4f9fc608cb726cb474c184fb61de%5E%21

tdf#122751 add fontwork and bullet stuff to NB's

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.