Bug 122761 - Artifacts on the draw toolbar
Summary: Artifacts on the draw toolbar
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected, regression
: 122773 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-16 15:54 UTC by Telesto
Modified: 2019-01-18 13:21 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (18.53 KB, image/jpeg)
2019-01-16 15:55 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-01-16 15:54:47 UTC
Description:
Artifacts on the draw toolbar

Steps to Reproduce:
1. Open Draw

Actual Results:
See screenshot

Expected Results:
No artifacts


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Telesto 2019-01-16 15:55:00 UTC
Created attachment 148363 [details]
Screenshot
Comment 2 Xisco Faulí 2019-01-16 17:11:26 UTC
Regression introduced by:

author	heiko tietze <tietze.heiko@gmail.com>	2019-01-11 13:14:46 +0100
committer	Heiko Tietze <tietze.heiko@gmail.com>	2019-01-15 14:05:45 +0100
commit b56ad2a1292b01647c4ee1f4364f7c4aa20fc449 (patch)
tree 3286fc974b635a87079698778de433e020a94064
parent dcf185ea162a4f593c66639cb3aebdc9c3d1a60f (diff)
Resolves tdf#122118 - Toolbar dropdown button triangles are too large
Fix values for toolbar expander triangles with 7px resp. 4px
depend now on the actual toolbar height.

Bisected with: bibisect-linux64-6.3

Adding Cc: to heiko tietze
Comment 3 Xisco Faulí 2019-01-16 23:37:18 UTC
*** Bug 122773 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2019-01-17 11:01:41 UTC
I proposed to revert it at https://gerrit.libreoffice.org/#/c/66507/, it's impossible to work in Draw with those artifacts...
Comment 5 Heiko Tietze 2019-01-17 14:16:48 UTC
(In reply to Xisco Faulí from comment #4)
> I proposed to revert it at https://gerrit.libreoffice.org/#/c/66507/, it's
> impossible to work in Draw with those artifacts...

Agreed, seems the calculation is wrong in my patch.
Comment 6 Commit Notification 2019-01-17 14:21:03 UTC
Xisco Faulí committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/59647fa4d190622cc6aae873de06a4dfe973bd54%5E%21

tdf#122761: Revert "Resolves tdf#122118 - Toolbar dropdown button triangles are too large"

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-01-18 13:21:23 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: cc7712ba4c70c035cbf080c5cf2f2eb6f9fe3eb1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded