Bug 122764 - find and replace dialog - regular expression missing
Summary: find and replace dialog - regular expression missing
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-01-16 16:59 UTC by raal
Modified: 2019-01-17 09:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2019-01-16 16:59:26 UTC
Description:
In Find and replace dialog is option regular expression missing

Steps to Reproduce:
1.open Find and replace dialog (ctrl+h)
2.unfold Other options


Actual Results:
option regular expression missing

Expected Results:
option regular expression is here


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 raal 2019-01-16 17:00:37 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks
 816b4626e42c392e6105a638add97bf199ceef57 is the first bad commit
commit 816b4626e42c392e6105a638add97bf199ceef57
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Fri Sep 18 11:06:25 2015 +0800

    source-hash-b80e865d369b4d94f29ac6dcc27379d3c6e72ada
    
    commit b80e865d369b4d94f29ac6dcc27379d3c6e72ada
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Mon Apr 29 14:44:11 2013 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Tue Apr 30 11:47:42 2013 +0100
    
        Convert find & replace dialog to .ui
    
        Change-Id: Ib5637a3601fc77588b2bd581f17dc6bcb36290db
Comment 2 Buovjaga 2019-01-16 18:41:56 UTC
Confirmed by me in 2015 https://bugs.documentfoundation.org/show_bug.cgi?id=37494#c7
Comment 3 Caolán McNamara 2019-01-17 09:18:03 UTC
In that old version where the regexp initially appears it will then eventually disappear if you click in and out of textboxes and/or switch windows a few times/use replace all. Help is also set up to hide the help for regexp if help is called for this page in impress (or draw).

So it seems the strong intent in the code was to hide the option in impress and its initial visibility seems to be a bug in that old version. I've no problem if someone wants to log a bug to show/enable the feature in impress (or draw then also) but then the someone attempting that will have to handle the inevitable follow up bugs arising from that.

So from the perspective of a regression that its not always hidden as opposed to initially shown in impress before becoming hidden I'm calling this NOTABUG