Bug Hunting Session
Bug 122772 - Table splits after AutoFilter popup menu use
Summary: Table splits after AutoFilter popup menu use
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2019-01-16 22:22 UTC by Jim Raykowski
Modified: 2019-07-25 04:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Raykowski 2019-01-16 22:22:14 UTC
Steps to repro:

1. Enter some data to cells in a column
2. Menu->Data->AutoFilter
3. Click on the AutoFilter popup menu button in cell
AutoFilter popup menu opens, cursor is in 'Search items...' edit box
4. Press down arrow key
cursor disappears
5. Press esc key
AutoFilter popup menu closes
6. Press down arrow
Table splits
7. Press arrow keys to split table horizontally and vertically

Results:
Table splits

Expected results:
Table cell navigation

Version: 6.3.0.0.alpha0+
Build ID: 8b461713c0c86bc19af739aada4b1345cfa5dfbe
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Durgapriyanka 2019-01-17 17:37:15 UTC
Thank you for reporting this bug. I confirm this in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Xisco Faulí 2019-01-18 13:04:24 UTC
Reproduced since the search field was added to the autofilter in https://cgit.freedesktop.org/libreoffice/core/commit/?id=f340278df616921c663075be692264ca37d86d84
Comment 3 Jim Raykowski 2019-07-16 20:48:53 UTC
Hi All, I have sent a patch for review for bug 122774 that also fixes this bug.