Download it now!
Bug 122809 - Save is not the default any more on macOS when trying to leave the app
Summary: Save is not the default any more on macOS when trying to leave the app
Status: RESOLVED DUPLICATE of bug 120977
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-18 17:19 UTC by William Gathoye
Modified: 2019-01-21 19:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Gathoye 2019-01-18 17:19:50 UTC
Description:
When the app asks us whether we want to save the document, don't save the document or cancel the operation when trying to leave the app, there is a regression with the branch 6.1.4. Save is not the default button on macOS any more.
Tested on Windows 10 and GNU/Linux with KDE Plasma 5 and the button was Save like it was before with 6.0.x.

Steps to Reproduce:
1. Open a document type some text
2. Try to leave LibreOffice without saving the app
3. The popup dialog ask us whether we want to Save the document, Do not save or Cancel the operation

Actual Results:
Cancel is the default

Expected Results:
Like with 6.0.7, Save is the default.


Reproducible: Always


User Profile Reset: No



Additional Info:
The user reports he is loosing quite a bunch of time when editing multiple documents. It seems like muscle memory is the cause since because of this REGRESSION, he doesn't press Tab before pressing Enter to save the document. As Cancel is selected by default, LibreOffice doesn't quit.
Comment 1 William Gathoye 2019-01-18 17:21:09 UTC
Link to the report made on the French instance of ask: https://ask.libreoffice.org/fr/question/178529/x/?answer=179896#post-id-179896
Comment 2 Xisco Faulí 2019-01-21 18:48:08 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 3 Xisco Faulí 2019-01-21 19:17:46 UTC
This is a duplicate of bug 120977 and it will be fixed in LibreOffice 6.1.5

*** This bug has been marked as a duplicate of bug 120977 ***