Bug Hunting Session
Bug 122813 - Cannot set links in linux for use in Windows and Linux on a nas (network attached storage)
Summary: Cannot set links in linux for use in Windows and Linux on a nas (network atta...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2019-01-19 10:24 UTC by Peter Kiesel
Modified: 2019-02-13 22:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Kiesel 2019-01-19 10:24:24 UTC
Description:
My english is bad, but I try it, my native language is german.
This problem is only present in a linux- and windows-environment. I use a nas-server from synology and use no data lokal, only over the nas (over lan). In windows I can set a link from a file from the nas to another file of the nas and I can work with this link as well in linux. The window (over menu in libreoffice) to set such link is equal in windows and linux. Now, I try the same action in linux and I cannot set such link over the file manager. At the file manager I see the link with file://smb... and set I the link with the precise syntax manually (caracter by caracter - step by step) it works. The link is stored and I can read the linked file in Windows. But I would like to set a link over the file manager and this is broken. I get the window with the file manager and I can choose the file, but the link is not stored. There is no error, only the link is not stored. To set links in a lokal environment in linux it is not a problem, only over the nas and samba. I use linuxmint 19, but the problem is universally. I think in the linux-menue there is no option to set such links to use it in windows and linux. A note: in the german-user-group you find this problem in german over https://document-foundation-mail-archive.969070.n3.nabble.com/Re-lt-Link-lasst-sich-bei-Nutzung-eines-NAS-als-Fileserver-nicht-erzeugen-gt-td4255935.html. And a second note: The problem is not new, it isn't only present in the current version of openoffice or linux.
I hope, I have write the problem so, that you can understand it. For reply I get you some more informations with good grace.
Peter

Steps to Reproduce:
1. In linux-libreoffice: choose web-link
2. In the new window choose local
3. Use the file manager symbol and choose the file
4. On the line for the link is no entry with file://smb...

Actual Results:
Only if the link in linux set to the entry with file://smb... works it in windows too and I think it is only a bug in linux.

Expected Results:
There ist no error-information, mostly the line for the link is empty.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Peter Kiesel 2019-02-11 12:59:32 UTC
(In reply to Peter Kiesel from comment #0)
> Description:
> My english is bad, but I try it, my native language is german.
> This problem is only present in a linux- and windows-environment. I use a
> nas-server from synology and use no data lokal, only over the nas (over
> lan). In windows I can set a link from a file from the nas to another file
> of the nas and I can work with this link as well in linux. The window (over
> menu in libreoffice) to set such link is equal in windows and linux. Now, I
> try the same action in linux and I cannot set such link over the file
> manager. At the file manager I see the link with file://smb... and set I the
> link with the precise syntax manually (caracter by caracter - step by step)
> it works. The link is stored and I can read the linked file in Windows. But
> I would like to set a link over the file manager and this is broken. I get
> the window with the file manager and I can choose the file, but the link is
> not stored. There is no error, only the link is not stored. To set links in
> a lokal environment in linux it is not a problem, only over the nas and
> samba. I use linuxmint 19, but the problem is universally. I think in the
> linux-menue there is no option to set such links to use it in windows and
> linux. A note: in the german-user-group you find this problem in german over
> https://document-foundation-mail-archive.969070.n3.nabble.com/Re-lt-Link-
> lasst-sich-bei-Nutzung-eines-NAS-als-Fileserver-nicht-erzeugen-gt-td4255935.
> html. And a second note: The problem is not new, it isn't only present in
> the current version of openoffice or linux.
> I hope, I have write the problem so, that you can understand it. For reply I
> get you some more informations with good grace.
> Peter
> 
> Steps to Reproduce:
> 1. In linux-libreoffice: choose web-link
> 2. In the new window choose local
> 3. Use the file manager symbol and choose the file
> 4. On the line for the link is no entry with file://smb...
> 
> Actual Results:
> Only if the link in linux set to the entry with file://smb... works it in
> windows too and I think it is only a bug in linux.
> 
> Expected Results:
> There ist no error-information, mostly the line for the link is empty.
> 
> 
> Reproducible: Always
> 
> 
> User Profile Reset: No
> 
> 
> 
> Additional Info:

At the last days I think about the problem and I tried somethings. My result is it is no bug. With the filemanager in linux I can copy the link and paste it to the link-array in libreoffice and this link goes on at windows too. The steps in linux are only diffent to windows and it takes a long time to understand it. Thank you and you can close the bug,
Peter