Download it now!
Bug 122819 - LibO6.2RC calc extra slow in selecting multiple cells with long text with SHIFT+MOUSE CLICK (seems to hang even if it actually does not)
Summary: LibO6.2RC calc extra slow in selecting multiple cells with long text with SHI...
Status: RESOLVED DUPLICATE of bug 120836
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-19 21:13 UTC by sergio.callegari
Modified: 2019-01-21 13:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2019-01-19 21:13:55 UTC
Description:
Seen with the KDE5 VCL, don't know if other VCL plugins show the same issue.

Have a calc spreadsheet where a row is made of cells with long texts in them (text spanning multiple lines with linebreaks).

Selecting these cells is extra slow in LibO6.2: you see an evident delay between the mouse click (for the selection) and the visual feedback (cell background changing color).

If you try to select multiple contiguous cells (e.g. select one cell and then press SHIFT and click on another cell), then LIBO6.2 becomes /extremely slow/ and seems to hang. In fact it does not hang. If you leave enough time to it (even minutes), then it does what it should.

At the same time on the terminal you may see tons of "QXcbClipboard: SelectionRequest too old" and CPU usage goes high (but not super-high).

Makes calc on 6.2 sort of not usable for this case.

Steps to Reproduce:
See description

Actual Results:
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Xisco Faulí 2019-01-21 13:18:47 UTC
Thanks for reporting this issue. it seems like a duplicate of bug 120836

*** This bug has been marked as a duplicate of bug 120836 ***