Bug 122838 - Modify-Style dialog is too tall (lots of unnecessary vertical space), pushing buttons off-screen (does not happen in 6.1 or before)
Summary: Modify-Style dialog is too tall (lots of unnecessary vertical space), pushing...
Status: RESOLVED DUPLICATE of bug 122480
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2019-01-20 23:22 UTC by Jim Avera
Modified: 2019-01-22 01:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the problem (380.87 KB, image/png)
2019-01-20 23:23 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2019-01-20 23:22:07 UTC
Description:
If a text style is modified, the dialog opens to an unnecessarily high height, so high that the buttons (OK, Cancel, etc.) at the bottom are off-screen and can not be pressed.

This may be a regression starting in 6.2 because the dialog opens at normal height in 6.1, 6.0, and 5.4.7.

This behavior occurs with a a new profile ( rm -rf $HOME/.config/libreoffice* first)

Steps to Reproduce:
1. Start Writer
2. Styles->Edit Style (or right-click->Modify in Style sidebar)

Actual Results:
Paragraph style modify dialog opens, containing a lot empty vertical space; the buttons at the bottom are off-screen where they can not be clicked.

Expected Results:
Dialog has the minimal height needed to contain its widgets.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.2.1.0.0+
Build ID: 9f00473b9c0352d95ab0f9e6cafb6d24a64fdb65
CPU threads: 12; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-01-10_05:03:06
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Jim Avera 2019-01-20 23:23:54 UTC
Created attachment 148459 [details]
Screenshot showing the problem
Comment 2 Dieter Praas 2019-01-21 07:00:56 UTC
I can't confirm with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 411f3a050ac2be598019d512f8ccfe041080c28f
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-14_03:17:11
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-01-21 16:42:22 UTC
Seems to be the same as bug 122480, which I can't confirm...

*** This bug has been marked as a duplicate of bug 122480 ***
Comment 4 Dieter Praas 2019-01-21 16:51:14 UTC
(In reply to Xisco Faulí from comment #3)
> Seems to be the same as bug 122480, which I can't confirm...

Jim, if you agree, it is the same, you can confirm that bug.
Comment 5 Jim Avera 2019-01-22 01:57:05 UTC
Agreed, it seems to be the same bug.