Bug Hunting Session
Bug 122885 - Crash when converting tdf#122811 file to Firebird
Summary: Crash when converting tdf#122811 file to Firebird
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.1.6
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2019-01-22 19:52 UTC by Julien Nabet
Modified: 2019-01-23 16:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (17.30 KB, text/plain)
2019-01-22 19:53 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2019-01-22 19:52:47 UTC
Description:
On pc Debian x86-64 with master sources updated some days ago, I got a crash when converting tdf#122811 file to Firebird

Steps to Reproduce:
1. Open https://bugs.documentfoundation.org/attachment.cgi?id=148491
2. Click table pane and try to open a table
=> migration dialog appears
3. Click yes/ok

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Julien Nabet 2019-01-22 19:53:21 UTC
Created attachment 148530 [details]
bt with debug symbols
Comment 2 Julien Nabet 2019-01-22 20:11:34 UTC
Tamas/Lionel: as you may have seen, I submitted a very straightforward patch.
(https://gerrit.libreoffice.org/#/c/66752/)
Comment 3 Commit Notification 2019-01-22 21:15:13 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/301ff4dfb82dfd961b993aec151784bd478b4f97%5E%21

tdf#122885: fix crash when converting odb file to Firebird

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Julien Nabet 2019-01-22 21:30:28 UTC
Backport for 6.2: https://gerrit.libreoffice.org/#/c/66754/
Comment 5 Xisco Faulí 2019-01-23 10:49:00 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 8f7c35072a6bbb33f6582c8c9a37a275c8d3cb14
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Julien Nabet, Thanks for fixing this crash!!
Comment 6 Xisco Faulí 2019-01-23 10:58:55 UTC
Seems to be linux only. I can't reproduce it in

Versión: 6.2.0.2
Id. de compilación: 2ce5217b30a543f7666022df50f0562f82be0cff
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

Cherry-picked to 6-1 -> https://gerrit.libreoffice.org/#/c/66786/
Comment 7 Commit Notification 2019-01-23 16:46:57 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/20295bbc58c36b28f4de9ce8d137684e9495216d%5E%21

tdf#122885: fix crash when converting odb file to Firebird

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-01-23 16:47:06 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/8f3e68310357e92ffdfe03471d3bdbd918c65e2e%5E%21

tdf#122885: fix crash when converting odb file to Firebird

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.