Bug 122892 - Writer hangs when deleting specific line
Summary: Writer hangs when deleting specific line
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.3 target:6.2.4
Keywords: bibisected, bisected, regression
: 118104 124281 (view as bug list)
Depends on:
Blocks: tdf#114306-regressions
  Show dependency treegraph
 
Reported: 2019-01-23 08:41 UTC by Rene Baumgartner
Modified: 2019-06-20 09:20 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
MasterTemplate_stripped (45.45 KB, application/vnd.oasis.opendocument.text-template)
2019-01-23 08:41 UTC, Rene Baumgartner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Baumgartner 2019-01-23 08:41:28 UTC
Created attachment 148542 [details]
MasterTemplate_stripped

Hi Developers,

My Office Writer crashes everytime when I try to delete a specific line.

Steps to reproduce:

1) Have LibreOffice Version: 6.0.7.3 (x64) installed on your Windows 10 Computer - OPTIONAL, had the same crash on Linux

2) Open the OTT file attached (MasterTemplate_stripped)

3) Delete the line right above of the "Offer" heading on page 3

4) Observe: Your Writer will freeze/crash (not respond in Task Manager)


A screenshot which shows the "nasty line" can be found here: https://ask.libreoffice.org/en/question/180224/writer-crash-when-deleting-specific-line/

Thanks a lot for your efforts,
Rene
Comment 1 Timur 2019-01-23 10:11:29 UTC
No repro 5.4 and 6.0, repro LO 6.3+ in Win7, Lin not tested. Looks like regression.
Comment 2 Xisco Faulí 2019-01-23 16:08:20 UTC
This seems to have begun at the below commit.
Adding Cc: to Manfred Blume; Could you possibly take a look at this one? Thanks

dacaa363b4ca5713c4f3536f91071c6008cb49f9 is the first bad commit
commit dacaa363b4ca5713c4f3536f91071c6008cb49f9
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Dec 21 15:36:28 2017 -0800

    source sha:18765b9fa739337d2d891513f6e2fb7c3ce23b50

author	Manfred Blume <manfred.blume@cib.de>	2017-12-08 15:01:51 +0100
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2017-12-22 00:20:40 +0100
commit	18765b9fa739337d2d891513f6e2fb7c3ce23b50 (patch)
tree	61acc1c9001d529d0df88affe48310187784cc99
parent	baaf6c12c8e9f785dc91e5d3db8b2f5072d4e3f5 (diff)
tdf#114306 fix unexpected page break in row-spanned table
Comment 3 Oliver Brinzing 2019-01-23 18:12:20 UTC
i can reproduce a freeze with 

Version: 6.1.5.1 (x64)
Build-ID: f18954c1ba9116b85c32b6bdbc0188d3e0fd24c7
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded

directly after loading the attached template.
Comment 4 Oliver Brinzing 2019-01-23 18:16:09 UTC
freeze is reproducible with LO 6.0.7.3, LO 6.2.0.2, but not with LO 5.4.7.2
Comment 5 Michael Stahl (CIB) 2019-02-26 18:19:10 UTC
https://gerrit.libreoffice.org/#/c/68402/
Comment 6 Michael Stahl (CIB) 2019-02-27 12:43:24 UTC
*** Bug 118104 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2019-03-04 10:09:51 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b7d4418c309c8bc4fd25485dd3a0ea6ad9edf34e%5E%21

tdf#122892 sw: fix IsPrepWidow() loop in SwTextFrame::CalcFollow()

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-03-04 10:09:58 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b891226dcee036fd8aad8320c7007b75b10b23c5%5E%21

tdf#122892 sw: fix disappearing rows after table split

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Michael Stahl (CIB) 2019-03-04 10:17:38 UTC
fixed on master
Comment 10 Commit Notification 2019-03-04 23:41:31 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/a551d277dc07fc0fbb3d58fd66c0686fe531126b%5E%21

tdf#122892 sw: fix IsPrepWidow() loop in SwTextFrame::CalcFollow()

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-03-04 23:41:38 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/5ccbdb6551931a18bb60a961455f93ac918cc7e8%5E%21

tdf#122892 sw: fix disappearing rows after table split

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2019-03-12 17:55:33 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 8aa579830b20072af8d6e149d6b279362fe98b91
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue! Do you think the commits should be backported to 6-1 branch ?
Comment 13 Michael Stahl (CIB) 2019-03-12 17:58:40 UTC
(In reply to Xisco Faulí from comment #12)
> Do you think the commits
> should be backported to 6-1 branch ?

dunno, on the one hand the fixes are rather obvious, on the other hand you can't change anything in layout without breaking some document or other...
Comment 14 Commit Notification 2019-05-06 15:49:53 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1caea03fcc6c24e38b2d1d9f6097ad84183ffefd%5E%21

tdf#122892 tdf#124366 sw: fix loop in SwTextFrame::CalcFollow()

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Michael Stahl (CIB) 2019-05-06 17:02:30 UTC
*** Bug 124281 has been marked as a duplicate of this bug. ***
Comment 16 Commit Notification 2019-05-06 18:34:53 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1c4b53909b2a1c99dfcb5bbbb1685e5100c503c6%5E%21

tdf#122892 tdf#124366 sw: fix loop in SwTextFrame::CalcFollow()

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-05-09 11:20:52 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-4":

https://git.libreoffice.org/core/+/880fa5382c0249f09584a9a7af498cecaa75a08c%5E%21

tdf#122892 tdf#124366 sw: fix loop in SwTextFrame::CalcFollow()

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.