Bug 122924 - Wrong placement of last_custom_common_grey.png in Colibre icon theme
Summary: Wrong placement of last_custom_common_grey.png in Colibre icon theme
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.3.0.1 target:6.4.0
Keywords:
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2019-01-24 10:40 UTC by Mike Kaganski
Modified: 2020-09-15 04:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-01-24 10:40:43 UTC
Using Colibre on Windows, in my debug build, I see repeated warnings when working with sidebar's Width list:

> warn:vcl:14484:4108:vcl/source/image/ImplImage.cxx:83: Failed to load stock icon svx/res/symphony/last_custom_common_grey.png

#define RID_SVXBMP_WIDTH_CUSTOM_GRAY "svx/res/symphony/last_custom_common_grey.png" is defined in svx/inc/bitmaps.hlst (aside with "svx/res/symphony/last_custom_common.png"), and is used in svx/source/sidebar/line/LineWidthPopup.cxx. The image itself for the Colibre theme is in the icon-themes/colibre/sw/res/sidebar/pageproppanel. Generated instdir/share/config/images_colibre.zip does not contain neither last_custom_common_grey.png, nor last_custom_common.png. Adding the images to the zip silences warnings.

The said images also are absent in the theme zip installed with 6.2.0.2.

Actually, I don't understand the rationale behind placing images in different directories in the icon theme development tree (like icon-themes/colibre/sw/res/sidebar/pageproppanel), instead of using the correct path as should be in the resulting archive. I wonder how many other icons don't get it to the packages despite being present; or get into places where they are not looked for.
Comment 1 Mike Kaganski 2019-01-24 11:23:32 UTC
Also:

> warn:fwk.uiconfiguration:6604:14640:framework/source/uiconfiguration/ImageArrayData.cxx:75:
> Failed to load image 'cmd/sc_configuredialog.png' from icon theme 'colibre'
Comment 2 andreas_k 2019-01-25 09:47:37 UTC
added sc_configuredialog to colibre but where is the command how made the zip file, cause I don't know why png files should not be included in the zip.
Comment 3 Commit Notification 2019-01-25 12:29:47 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/20806e4c2e18762c2036153fc1a3a7b838a2956a%5E%21

tdf#122924 add configuredialog icons to colibre

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2019-03-13 18:41:41 UTC
A polite ping to Andreas Kainz:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 5 Commit Notification 2019-04-09 05:20:02 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b3d415fb3e740f873d64c2138db5d7186e9561fe%5E%21

tdf#122924 wrong link in colibre links.txt

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 andreas_k 2019-04-09 20:39:20 UTC
should be fixed can someone verify the fix
Comment 7 Mike Kaganski 2019-04-09 21:31:20 UTC
(In reply to andreas_k from comment #6)

Unfortunately, the image is still missing from icon package, and the problem is still there...
Comment 8 Commit Notification 2019-06-24 20:23:36 UTC
rizmut committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/01264190af208d3455c7f37b577ef23df37de382%5E%21

Colibre: Fix for tdf#122924, tdf#126044

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-06-24 21:54:13 UTC
rizmut committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0f676219fd0c2e3ada0ca3cfc77a7c9a2b2ed451%5E%21

Colibre: Fix for tdf#122924, tdf#126044

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.