Bug 122935 - FILESAVE DOCX Date field language changes
Summary: FILESAVE DOCX Date field language changes
Status: RESOLVED DUPLICATE of bug 99236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx, implementationError
Depends on:
Blocks:
 
Reported: 2019-01-24 15:18 UTC by NISZ LibreOffice Team
Modified: 2019-01-28 08:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Calc with a date field. (8.57 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-24 15:19 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Calc. (119.54 KB, image/png)
2019-01-24 15:22 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-01-24 15:18:13 UTC
Description:
Date language in DOCX documents created and reloaded with LibreOffice Writer 6.3.0.0.alpha0+.

Steps to Reproduce:
    1. Create a new document in LibreOffice Writer 6.3.0.0.alpha0+
    2. Insert Date Field
    3. Change the Date Format to 1999. december 31.
    4. Save the file as DOCX
    5. Reload the document
    6. Notice, that date language changes to English

Actual Results:
Date language changes to English.

Expected Results:
Date language should be Hungarian.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-01-24 15:19:48 UTC
Created attachment 148601 [details]
Example file from Calc with a date field.
Comment 2 NISZ LibreOffice Team 2019-01-24 15:22:40 UTC
Created attachment 148602 [details]
Screenshot of the problem in Calc.
Comment 3 Durgapriyanka 2019-01-24 16:57:59 UTC
Thank you for reporting the bug. I can confirm the bug in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Buovjaga 2019-01-27 16:57:49 UTC
It has been like this since it started working in 5.0. Version 4.4 and older do not save the date or date field.
Comment 5 Gabor Kelemen (allotropia) 2019-01-28 08:30:40 UTC
Sorry for the noise...

*** This bug has been marked as a duplicate of bug 99236 ***