Download it now!
Bug 122963 - FILESAVE DOCX Shape changes size and position
Summary: FILESAVE DOCX Shape changes size and position
Status: RESOLVED DUPLICATE of bug 122962
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2019-01-25 12:01 UTC by NISZ LibreOffice Team
Modified: 2019-04-15 15:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The original file (3.35 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-25 12:02 UTC, NISZ LibreOffice Team
Details
The saved file. (3.33 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-25 12:02 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Writer. (302.59 KB, image/png)
2019-01-25 12:02 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-01-25 12:01:47 UTC
Description:
After saving the attached original file in LO as docx the vertical rectangle goes missing on page 8.

Steps to Reproduce:
    1. Open the original file in LO.
    2. Save the file as docx.
    3. Reopen the file.
    4. Notice the missing shape.

Actual Results:
The vertical rectangle goes missing after saving in LO.

Expected Results:
The vertical rectangle goes missing after saving in LO.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-01-25 12:02:18 UTC
Created attachment 148647 [details]
The original file
Comment 2 NISZ LibreOffice Team 2019-01-25 12:02:35 UTC
Created attachment 148648 [details]
The saved file.
Comment 3 NISZ LibreOffice Team 2019-01-25 12:02:54 UTC
Created attachment 148649 [details]
Screenshot of the original and exported document side by side in Writer.
Comment 4 Durgapriyanka 2019-01-25 17:23:02 UTC
Thank you for reporting the bug.I can confirm this bug in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 5 Buovjaga 2019-02-03 15:36:18 UTC
3.5.0 does not show the shape on fileopen.

Checked that this appears in 43max on Linux. I suspect this is a duplicate of bug 122962. I did not bibisect as it is so infuriating due to the skipped commits. Feel free to try.
Comment 6 Buovjaga 2019-04-15 15:25:29 UTC
After bibisect with win32-4.3, same blame as bug 122962. For the bad state, I targeted both "gone" and "height decreased".

*** This bug has been marked as a duplicate of bug 122962 ***