Bug Hunting Session
Bug 122969 - Choppy zooming in & out in a document with lots of comments
Summary: Choppy zooming in & out in a document with lots of comments
Status: RESOLVED DUPLICATE of bug 61558
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, perf, regression
Depends on:
Blocks: Writer-Comments Zoom-Issues
  Show dependency treegraph
 
Reported: 2019-01-25 14:19 UTC by Telesto
Modified: 2019-02-15 11:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (544.39 KB, application/vnd.oasis.opendocument.text)
2019-01-25 14:19 UTC, Telesto
Details
Callgrind output from master (1.52 MB, application/x-xz)
2019-02-03 16:06 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-01-25 14:19:33 UTC
Description:
Sluggish zooming in & out. Bug docu

Steps to Reproduce:
1. Open the attached file
2. Go to single page view
3. CTRL+Scroll wheel

Actual Results:
Choppy experience (with lots of delays)

Expected Results:
Relative smooth experience


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

and in
Version: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba

No repro with
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 1 Telesto 2019-01-25 14:19:53 UTC
Created attachment 148658 [details]
Example file
Comment 2 Durgapriyanka 2019-01-25 18:44:07 UTC
Thank you for reporting the bug. I confirm the bug in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded 

and in

Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group threaded
Comment 3 Buovjaga 2019-02-03 14:31:29 UTC
Tried on Linux, but it is choppy in 43max, 42max, 41max, the oldest of 43all...
Comment 4 Telesto 2019-02-03 15:13:25 UTC
So more a profiling type of bug
Comment 5 Buovjaga 2019-02-03 16:06:37 UTC
Created attachment 148872 [details]
Callgrind output from master

Seemed to be impossible to combine tracing + scrolling zoom, so I zoomed with the bottom bar slider. Seems to be slow either way.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 8fbad2f600cd3ab81e7c1da0e4a2a71ebcac0553
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 31 January 2019
Comment 6 Buovjaga 2019-02-15 11:44:43 UTC

*** This bug has been marked as a duplicate of bug 61558 ***