Download it now!
Bug 122986 - Bad icons with Hi-DPI on Windows
Summary: Bad icons with Hi-DPI on Windows
Status: CLOSED DUPLICATE of bug 119020
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2019-01-26 01:15 UTC by baldzhang
Modified: 2019-01-28 22:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
bad icons (190.68 KB, image/png)
2019-01-26 01:19 UTC, baldzhang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baldzhang 2019-01-26 01:15:12 UTC
Description:
I have 3 laptops with 4k display run with Windows 10.
2 of them are fresh installed with Windows 10 1809, then installed libreoffice 6.1.2-x86 64
after start second time, the icons became crap...

tested has been done:
1) disabled Hi-DPI scaling, it's good
2) OpenGL disabled/enabled, it's all bad
3) revert one laptop to 6.0.x, it's good.
4) the third laptop is good. OS was installed long time ago
5) 2nd and 3rd laptop was exactly same hardware, one is good, another is bad.
6) upgraded to 6.1.3, 6.1.4, is all bad.
7) after delete all UserProfile, it good on first time running, then becaome bad.

Actual Results:
icons crap

Expected Results:
should be right icons


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: zh-CN
Module: StartModule
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 baldzhang 2019-01-26 01:19:27 UTC
Created attachment 148668 [details]
bad icons
Comment 2 Mike Kaganski 2019-01-26 07:39:08 UTC
This *must* be duplicate of bug 119020; and so it must be fixed in 6.1.4 - which means that after removing cached corrupted icons, that version must create good icons.

But your description doesn't specify on which versions did you try to "delete all UserProfile" (which removes the icon cache), after which "then becaome bad". If it's on 6.1.4, then it's something different (?).

Please clarify if clearing icon cache (see bug 119020 comment 55), or user profile, still gives you bad icons with *version 6.1.4*.

And please always set Version field to *earliest* affected (as hinted in the field for a purpose).
Comment 3 baldzhang 2019-01-26 19:49:14 UTC
tested with bug 119020 comment 55, my issue is gone, it's good now.

I do the cleaning at version 6.1.3, it not good at that version.
Next time I'll give the correct version info.

Thanks a lot, and I think this one could be closed.
Comment 4 V Stuart Foote 2019-01-27 20:01:04 UTC

*** This bug has been marked as a duplicate of bug 119020 ***