Bug 122989 - Update check item is available in Notebookbar Groupedbar without function if online update module is not installed
Summary: Update check item is available in Notebookbar Groupedbar without function if ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.3
Keywords: implementationError
Depends on:
Blocks: Notebookbar-Groupedbar
  Show dependency treegraph
 
Reported: 2019-01-26 09:19 UTC by OfficeUser
Modified: 2019-03-28 12:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (97.78 KB, image/jpeg)
2019-01-26 09:19 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2019-01-26 09:19:54 UTC
Created attachment 148673 [details]
Screenshot

Update check item is available without function if online update module is not installed. Clicking on it has no effect.

Solution: Hide check for update item if only update module is not installed.

See attached screenshot.

(Set keyword regression because update item does not and has never appeared in main menu or anywhere else in LibreOffice before notebook bar has been implemented.)
Comment 1 Buovjaga 2019-01-26 09:24:14 UTC
It is not a regression in the Notebookbar development history, thus marking as implementationError
Comment 2 OfficeUser 2019-01-26 10:30:12 UTC
Set to NEW based on Buovjaga's comment.
Comment 3 Buovjaga 2019-01-26 12:23:44 UTC
(In reply to OfficeUser from comment #2)
> Set to NEW based on Buovjaga's comment.

Nope. Please give exact steps on what we need to do to see the menu in your photograph. I searched for it, but was unable to find it.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 4 OfficeUser 2019-01-26 14:39:05 UTC
Found using
Version: 6.2.0.2 (x64)
Build-ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU-Threads: 8; BS: Windows 6.1; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded


Steps:
- Install LibreOffice without the online update module
- Start a LibreOffice app (for example Writer)
- Enable Notebookbar
- Click the Menu drop down button of the Notebookbar (see attached screenshot)

Result: The check update item is displayed. Clicking it has no effect.

Expected result: Check update menu should be hidden (if online update module) is not installed. (Suppression of check update item works as expected for the main menu. Thus it is an implementation error in the Notebookbar.)
Comment 5 Buovjaga 2019-01-26 15:03:23 UTC
Still missed the important bit, but I found it: you have to select one of the Groupedbar variants.

Version: 6.3.0.0.alpha0+
Build ID: 3a4d46c586352939a37e3b07fa74cbce81abd722
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 6 OfficeUser 2019-01-28 15:32:22 UTC
Reset Importance to "normal" because users could think they use recent version because there is no feedback when clicking this item. It is security related.
Comment 7 Buovjaga 2019-01-28 18:06:16 UTC
(In reply to OfficeUser from comment #6)
> Reset Importance to "normal" because users could think they use recent
> version because there is no feedback when clicking this item. It is security
> related.

It isn't security related. Resetting back to minor.
Comment 8 OfficeUser 2019-01-29 20:26:38 UTC
Like already stated, clicking "Check for Updates" without any message displayed as result will very likely be interpreted as "Most recent version already installed". So it is indirect security related.

--> Normal.


@Buovjaga please don't flood issues.
Comment 9 Adolfo Jayme 2019-03-27 09:47:41 UTC
6.3.0:
https://gerrit.libreoffice.org/plugins/gitiles/core/+/98174e163348ab44461f114142bc546e97720eec%5E%21

6.2.3:
https://gerrit.libreoffice.org/plugins/gitiles/core/+/4b46adb58e843dacc0e5448fb1e598ed97c89e93%5E%21

(Not closing the bug because, as stated in the above commits, this is a workaround. Before the stupid nag bot touches this bug…)
Comment 10 Thorsten Behrens (CIB) 2019-03-28 12:23:01 UTC
I'd close this as fixed - for extensions to properly work with the Notebookbar, some extension points need to be added (see commit message). But that's a different, and much more general, enhancement request.