Download it now!
Bug 122996 - LibreOffice BASE Table cannot alter Field Column Width via Width Dialog
Summary: LibreOffice BASE Table cannot alter Field Column Width via Width Dialog
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Tables
  Show dependency treegraph
 
Reported: 2019-01-27 14:02 UTC by Peter Banks
Modified: 2019-01-27 18:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screen shot of problem with dialog (48.22 KB, image/png)
2019-01-27 18:07 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Banks 2019-01-27 14:02:23 UTC
Description:
I am using BETA version 6.2

When creating a New Database or Accessing an Existing Database while EDITING.

In Tables "Open Database Object"

I can right click a Field Column and select Column Width but cannot ALTER its Width. In fact it is quite easy to lose the Column!

Steps to Reproduce:
1. Open a DataBase and select "Tables" the "Open DataBase Object"
2. Right click a column heading and select "Column Width"
3. You will NOT be able to ALTER the Width

Actual Results:
See above

Expected Results:
One should be able to alter the width of the column to fit the data in the Field. NOTHING can be done.


Reproducible: Always


User Profile Reset: No



Additional Info:
The column width should increase or decrease as required
Comment 1 Drew Jensen 2019-01-27 17:59:58 UTC
Using Ubuntu 18.04.1 and LO 6.2 RC2 I was unable to confirm the problem.

I was able to open a Table View window and change the display size for any column, but either double clicking on the column header which expands the column size to show the text contained, or , by grabbing the right edge of the column header with the mouse and dragging it to the right.

I tried with multiple SDBC drivers since you didn't name which one you used.

Perhaps someone with a 32 bit Windows install will have different results.
Comment 2 Drew Jensen 2019-01-27 18:07:49 UTC
Created attachment 148690 [details]
screen shot of problem with dialog

Ah - then I went back tried doing with the width dialog you mention.

You are correct that does not work. 

The screen shot shows the dialog immediately upon opening, after making the column with data larger then the default directly by dragging the side of header with mouse: Note the control for setting the size is disabled while the automatic checkbox is empty - this seems backwards.

Put a check mark in the Automatic field and the actual size box becomes active, allowing you to enter a different size, but since the automatic option is now active when you save this the "Automatic" width setting wins.
Comment 3 Drew Jensen 2019-01-27 18:11:21 UTC
So I will confirm this issue and change the status line also to reflect that it is the Dialog behavior that is broken.