Bug Hunting Session
Bug 123013 - Can not change Trendline name in charts in GTK3
Summary: Can not change Trendline name in charts in GTK3
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: All Linux (All)
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords: bibisected, regression
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2019-01-28 11:21 UTC by andis.lazdins
Modified: 2019-04-15 13:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file with chart with trendline (15.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-01-28 11:22 UTC, andis.lazdins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2019-01-28 11:21:52 UTC
Description:
It is not possible to put cursor in the Trendline Name of Charts to add a name or to change it.

Steps to Reproduce:
1.Open attached file.
2.Enter chart and select trendline
3.Click on format selection
4.Try to put cursor into Trendline Name field

Actual Results:
It is not possible to put cursor in the form.

Expected Results:
Trendline name field is selected and text can be entered


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 andis.lazdins 2019-01-28 11:22:44 UTC
Created attachment 148707 [details]
Sample file with chart with trendline
Comment 2 Timur 2019-01-28 15:14:07 UTC
I do not repro with LO 6.2 or 6.3+ in Windows.
Comment 3 Timur 2019-01-28 15:28:13 UTC
Repro in Linux Mint with LibreOfficeDev-6.3.0.0.alpha0_2018-12-29-x86_64.AppImage.
Comment 4 Xisco Faulí 2019-01-28 17:08:40 UTC
GTK3 only
Comment 5 Xisco Faulí 2019-01-28 17:17:09 UTC
Hi Caolán, I'm wondering if this issue was introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=39aa91cfb4620a650ceba01076a1c0aa2fbfdadf...
I can reproduce it at that point, but before that it crashes...
Comment 6 Xisco Faulí 2019-01-28 17:24:31 UTC
My take: https://gerrit.libreoffice.org/#/c/67026/
Comment 7 Commit Notification 2019-01-29 08:55:17 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/11853548fcc62b96a784cb81f7ec4e4bb78adfee%5E%21

tdf#123013: Allow to change trendline name in gtk3

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-01-29 08:55:29 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/08f7f8e1b8058fb4697047cec27bdbeeaf4964c0%5E%21

tdf#123013: Allow to change trendline name in gtk3

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-01-31 14:32:31 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2bb6cbedcbe2004e4959bd2cf562f71a2933324f%5E%21

uitest for bug tdf#123013

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 andis.lazdins 2019-04-02 04:04:37 UTC
The problem is solved in 6.2.3.1.
Thanks!