Bug Hunting Session
Bug 123099 - Creating new "HSQLDB Embedded" database immediately brings up migration-to-Firebird dialog
Summary: Creating new "HSQLDB Embedded" database immediately brings up migration-to-Fi...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.1
Keywords:
Depends on:
Blocks: Database-Firebird-Migration
  Show dependency treegraph
 
Reported: 2019-02-01 10:06 UTC by Stephan Bergmann
Modified: 2019-08-07 21:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Bergmann 2019-02-01 10:06:25 UTC
At least with recent master (where Firebird is enabled, even without enabling "Tools - Options... - LibreOffice - Advanced - Optional Features - Enable experimental features (may be unstable)"), "File - New - Database", keeping the pre-selected "Create a new database - Embedded database: HSQLDB Embedded", then "Finish", specifying a "Name" and "Save" brings up the "Confirm Migration: The document contains embedded HSQL data, which is deprecated. Would you like to migrate to Firebird now?" dialog.

It feels odd that when deliberately creating an "HSQLDB Embedded" db one is immediately asked whether to migrate it.

Maybe instead the default in the Database Wizard should be changed from "HSQLDB Embedded" to "Firebird Embedded"?
Comment 1 Alex Thurgood 2019-02-01 10:51:48 UTC
Confirming with

Version: 6.3.0.0.alpha0+
Build ID: ce2b98580b9f36d6f358bd2c9c027d3d82cb33d7
CPU threads: 8; OS: Mac OS X 10.14.2; UI render: default; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2019-01-30_01:04:02
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Alex Thurgood 2019-02-01 10:52:49 UTC
IMO, this shouldn't happen when one deliberately chooses to create an embedded hsqldb.
Comment 3 Alex Thurgood 2019-02-01 10:54:58 UTC
This is similar to the behaviour in regard to macro instantiated dbcontext connections, where the message gets displayed each time (already declared bug).
Comment 4 Xisco Faulí 2019-02-05 16:55:09 UTC
Not a regression. It can be reproduced since the migration dialog was introduced in https://cgit.freedesktop.org/libreoffice/core/commit/?id=5b0ceb86c342754d8f4e83408c7ae0da0e3931d3


> Maybe instead the default in the Database Wizard should be changed from
> "HSQLDB Embedded" to "Firebird Embedded"?

I get Firebird Embedded as the default

Version: 6.3.0.0.alpha0+
Build ID: f8c4459bbda62cb905d0c007cac044f3410ab76b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Stephan Bergmann 2019-02-06 12:13:47 UTC
(In reply to Xisco Faulí from comment #4)
> > Maybe instead the default in the Database Wizard should be changed from
> > "HSQLDB Embedded" to "Firebird Embedded"?
> 
> I get Firebird Embedded as the default

addressed now with <https://gerrit.libreoffice.org/#/c/67449/> "Make Firebird the (unconditional) default for new databases"
Comment 6 Xisco Faulí 2019-02-06 12:48:26 UTC
(In reply to Xisco Faulí from comment #4)
> I get Firebird Embedded as the default
> 
> Version: 6.3.0.0.alpha0+
> Build ID: f8c4459bbda62cb905d0c007cac044f3410ab76b
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded

Ok, I can reproduce the problem and I get HSQLDB if I use a clean profile...
Comment 7 Xisco Faulí 2019-07-31 09:29:13 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2019-07-31 12:46:39 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/77ef0a92b3bd19f836d0fcb2a41af5e643129283%5E%21

tdf#121599, tdf#123099: ignore migration dialog when

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-08-07 21:28:02 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/2b0d0863ebe39a964a927b3867aef277700f0066%5E%21

tdf#121599, tdf#123099: ignore migration dialog when

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.