Bug Hunting Session
Bug 123108 - FILESAVE XLSX Shape outline changes color
Summary: FILESAVE XLSX Shape outline changes color
Status: RESOLVED DUPLICATE of bug 124013
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, filter:xlsx, regression
Depends on:
Blocks: OOXML-Object-Fill OOXML-Shapes
  Show dependency treegraph
 
Reported: 2019-02-01 10:45 UTC by NISZ LibreOffice Team
Modified: 2019-04-14 08:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The original file (17.84 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-02-01 10:45 UTC, NISZ LibreOffice Team
Details
The saved file. (17.72 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-02-01 10:46 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Calc. (316.14 KB, image/png)
2019-02-01 10:46 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-01 10:45:04 UTC
Description:
When the attached document gets saved in LO the shapes other than the arrows change their outline and fill color to white.

Steps to Reproduce:
    1. Open the attached document in LO.
    2. Save it as xlsx.
    3. Reload it.
    4. Notice the changes.

Actual Results:
Shapes other than the arrows outline and fill color is white.

Expected Results:
They should stay as they were before.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-02-01 10:45:44 UTC
Created attachment 148839 [details]
The original file
Comment 2 NISZ LibreOffice Team 2019-02-01 10:46:01 UTC
Created attachment 148840 [details]
The saved file.
Comment 3 NISZ LibreOffice Team 2019-02-01 10:46:17 UTC
Created attachment 148841 [details]
Screenshot of the original and exported document side by side in Calc.
Comment 4 Durgapriyanka 2019-02-01 17:36:17 UTC
Thank you for reporting the bug.I can confirm the bug in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 5 Buovjaga 2019-02-10 19:33:12 UTC
Bibisected with 43max to range https://gerrit.libreoffice.org/plugins/gitiles/core/+log/160db96a882a2be8c3307e8a04beda4ae93a13c4..5f893db57dad1a287842cfca4c78606707c34390

There were commits, where the outlines were preserved, but the brown fill of the skewed boxes was gone. I marked those as bad as well.
Comment 6 Buovjaga 2019-04-13 20:48:33 UTC
With win32-4.3, the fill color change turned out to be bc0a9076aa43a0782bcf81e55d3f84f6af0f68e8 which is reported as bug 124013.

I could do a bibisect strictly for the outline change later and we can change the summary.
Comment 7 Buovjaga 2019-04-14 08:14:10 UTC
Bibisected the outline issue and it is bug 97057

*** This bug has been marked as a duplicate of bug 124013 ***