Bug 123179 - Filesave: Saving document with images linkend to file increased from 3 sec to 8 sec
Summary: Filesave: Saving document with images linkend to file increased from 3 sec to...
Status: RESOLVED DUPLICATE of bug 119933
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks: Save Files-Linked
  Show dependency treegraph
 
Reported: 2019-02-05 11:55 UTC by Telesto
Modified: 2019-02-12 20:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample file (134.98 KB, application/x-zip-compressed)
2019-02-05 11:55 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-02-05 11:55:27 UTC
Description:
Filesave: Saving document with images linkend to file increased from 3 sec to 8 sec

Steps to Reproduce:
1. Open attached file & extract
2. Open File & Save As

Actual Results:
Saving takes around 8 seconds

Expected Results:
3 seconds or so


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

but not in
4.4.7.2
Comment 1 Telesto 2019-02-05 11:55:48 UTC
Created attachment 148901 [details]
Sample file
Comment 2 Durgapriyanka 2019-02-06 16:42:42 UTC
Thank you for reporting the bug. I confirm the bug is present. It takes more than 8 secs for me to save.

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-02-07 21:39:20 UTC
Seems to be win only... I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 31d3369803ce4eceab5ef708f2cd33748b6d10ea
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

BTW, would you mind retesting it in master after my commit -> https://cgit.freedesktop.org/libreoffice/core/commit/?id=a7da594593eb2d63004a91dc471683713ce9742a ?
Comment 4 Buovjaga 2019-02-12 19:41:29 UTC
Blames commit 27008aa028cde8d270e898c5743a9fe5c7701dab like bug 119933 (win32-6.1 repo). I tested bug 119933 on Linux and could not repro. So we have a filesave and fileopen bug blaming the same commit, both only on Win. Should we dupe this?
Comment 5 Telesto 2019-02-12 20:11:50 UTC

*** This bug has been marked as a duplicate of bug 119933 ***